Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There are multiple open bugs about NFS for Debian unstable right now.

One description of the problem says that the breakage is triggered by nfs-kernel-server transition to rpcbind - and rpcbind and portmap cannot bind the same port at the same time. However, rpcbind package does not have an init.d script at all, although it seemed to work on my client when started manually (my server is broken as well, so I didn't check it fully).

However, I do not wish for a manually started service on a server that may be rebooted at any time - and I don't wish for a hacky script written by me or some random guy.

So, I'm looking for the "official" solution fixing NFS usage for Debian that doesn't involve manual hacking. The proper solution will obviously take some time, but a good interim solution what is needed by every Debian NFS user world wide.

share|improve this question
add comment

2 Answers 2

There are workarounds given in the bug report. The first you dont want (running rpcbind manually). The second - NEEDS_STATD=no and -o nolock - works fine for me here. The other option in the beg report thread is to use nfs4, in which case you can just set NEEDS_STATD=no.

Note, the referenced workrounds mistakenly says "-o lock", which should be "-o nolock".

There is unlikely to be an "official" solution. Just keep an eye on the bug reports to see how people are coping with the issue. Instead of an "official" solution, the problem will likely just be fixed - either by fixing rpc.statd, or adding an init script to rpcbind.

share|improve this answer
    
NEEDS_STATD=no fixes nfs-common init script starting, but when attempting to export the filesystems, mountd fails similarily to statd. Hence I think your suggestions do not work for nfs servers. And I'd rather avoid nfs4. But, your answer was helpful, nonetheless. –  Nakedible Jan 6 '10 at 15:51
add comment
up vote 1 down vote accepted

Problem solved officially, rpcbind package now contains init script, dependencies changed all around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.