Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I see this is a common problem, however I don't understand the resolution.

I have Windows 7 64 bit installed, and a separate graphics card (GeForce 7900 GS). Is the entire 4 GB of main RAM usable, or is 1200 MB wasted because of address conflicts?


  1. I definitely have windows 64 bit, not 32 bit.
  2. Each memory chip shows as 2GB on its own. Only when combined, they show as 2814 MB.
  3. I've tried different slots.
  4. Both memory chips are the exact same model.
  5. The checkbox in msconfig (boot/advanced/max-mem) is not checked.
  6. I actually have Windows 7 RC and not RTM, not sure that it matters though.
share|improve this question
Could you provide some hardware specs? Such as brand names and model numbers? – Qwerty Jan 5 '10 at 23:45
The memory is by kingstone, could the model be ValueRam? – ripper234 Jan 5 '10 at 23:50
The model would be a string of letters and numbers like "KVR533D2S4/2G". Also please run memtest, give us the results, and tell us what your BIOS (before windows starts) shows the total memory as. – davr Jan 6 '10 at 23:12
Could you provide details regarding the motherboard model. I have had this happen with a board that although it was certified for 4GB the fine print stated it will only see X amount. Sometimes the lower range brands don't even claim this. – BinaryMisfit Jan 18 '10 at 16:29
This is what Everest says on my motherboard: "Epox EP-5LDA+ GLI" – ripper234 Jan 22 '10 at 11:55

Try booting a Linux Live CD, or even just Memtest86+, and seeing how much memory that reports. That will help sort out whether you have a hardware issue or a software issue.

share|improve this answer
Will do, just didn't find the time yet. – ripper234 Jan 7 '10 at 11:06
Memtest86 reports 2814 MB of memory. – ripper234 Jan 22 '10 at 17:31
Then, it is unlikely any operating system will show you the entire 4GB. If you are running a 7900GS I'm thinking it is an older AGP system, and may have chipset limitations on how much memory is recognized. Please tell us what CPU, Motherboard mfg and model, and BIOS version you have. – kmarsh Jan 25 '10 at 14:00
OK, I see it is a Epox EP-5LDA+ GLI. What CPU? Having a Celeron might limit recognized memory. According to this page, it is a 945P and should recognize 8GB of memory. – kmarsh Jan 25 '10 at 14:05

Start > Run > Type msconfig and click OK

go to Boot > Advanced

is the box 'Maximum Memory' checked?

share|improve this answer
Should it be? If not, why not? – Patriot Jan 5 '10 at 20:43
by default it shouldn't. – Molly7244 Jan 5 '10 at 20:46
It is not checked. If I try to check it, the maximum that it allows is 2816. – ripper234 Jan 5 '10 at 22:31
does the board have an onboard video controller? if yes, disable it in the BIOS – Molly7244 Jan 5 '10 at 22:57
No, it does not have an onboard video card. – ripper234 Jan 5 '10 at 23:50

From what you said about the memory, the problem is one of two:

  • You are actually running 32-bit Windows 7. Right click on Computer and go to properties. Ensure you are running the 64-bit version.
  • There is a problem with your memory. Swap out sticks until you can make sure all memory is working. Also make sure your memory is the same, if you mix and match some of it might be dropping off. Use memtest86 to run through your RAM bit by bit and ensure proper usage.
share|improve this answer
This is 2 brand new sticks. Each separately reads as 2 gigs. Only combined, there is a problem. I also tried different slots. – ripper234 Jan 5 '10 at 22:32
And I am definitely running 64bit windows 7. – ripper234 Jan 5 '10 at 22:33
How does your PC fare on memtest86? I've had half a stick of ram go bad before. Only memtest86 picked it up, but when I would boot into windows it would randomly crash. – Dave Drager Jan 6 '10 at 15:41

It's a common problem with 32-bit (non-Server) Windows. But with 64-bit you should be able to use all your RAM.

EDIT: Download MemInfo. Extract the AMD64 version and from an Administrator prompt, run meminfo -r. For example, on this 6GB system, I get:

MemInfo v2.10 - Show PFN database information
Copyright (C) 2007-2009 Alex Ionescu

Physical Memory Range: 0000000000001000 to 000000000009F000 (158 pages, 632 KB)
Physical Memory Range: 0000000000100000 to 00000000DFEF0000 (916976 pages, 3667904 KB)
Physical Memory Range: 0000000100000000 to 00000001A0000000 (655360 pages, 2621440 KB)
MmHighestPhysicalPage: 1703936

It starts with the classic 640KB (or thereabouts); then the memory under 4GB, up to memory-mapped IO region (which on this particular system is) around DFF0 0000, and then finally the re-mapped memory placed above the 4GB boundary. (Each page is 4KB.)

share|improve this answer
Well ... I can't :( – ripper234 Jan 5 '10 at 22:43

Does the bios show the full amount of memory when both sticks are in? Quick way to see if it is bad memory.

share|improve this answer

In your BIOS is there a memory remapping or a memory hole setting? That may have to be enabled for the RAM to be usable by Windows. Otherwise the RAM address will conflict with the addresses used by your hardware and be unusable.

It is also possible it is a hardware limitation of the chip set on your motherboard.

What motherboard do you have?

share|improve this answer

It's not the same. The link you pointed to refers to the 32 bit version of vista, which absolutely is limited to ~3GB of ram.

64 bit is a whole different animal. You should have access to all that RAM. I run 64 bit vista at home, and I've got 8GB of RAM installed with no problems at all.

@Ripper: The point is, you're stuck with a 32bit address space. It's the only explanation for the 3 gig limit. 64 bit computing has a limit, but it's nowhere near 3 gigs (though Microsoft does cripple the memory limits of certain versions of Windows)

share|improve this answer
OK, but that doesn't really answer my question ... I have Windows 7 64 bit, and am seeing this phenomenon. – ripper234 Jan 5 '10 at 22:31
Also at work I have a similar setup just without the GPU, and I see 4 Gigs with no problems. This does't change the fact that at home I am seeing only 2814 mb. – ripper234 Jan 5 '10 at 22:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .