Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The directory is in fact empty according to FTP, how can I delete this directory even though SmartFTP is throwing this error?

share|improve this question

migrated from stackoverflow.com Jan 5 '10 at 20:28

This question came from our site for professional and enthusiast programmers.

5 Answers 5

up vote 1 down vote accepted

Set full permissions on folder first, then try deleting it again:

CHMOD 777 <folder>

Also check it does not contain files with names that begin with ".", as these may appear hidden. Eg,

DELETE .htaccess
share|improve this answer

Is someone else using that directory?

share|improve this answer

FTP isn't a reliable way to check to see if a directory is empty or not. Do you have local access to the machine?

share|improve this answer

Check first if you have a permission to rename it, if not then John is right that folder is not owned by you.

share|improve this answer

This is usually caused by hidden files.

In SmartFTP:

  1. Select Favorites > Edit Favorites from the SmartFTP menu. The SmartFTP Favorites window appears.
  2. From the SmartFTP Favorites window select the Favorite FTP login. Right click on the Favorite and select Properties. The Properties dialog appears.
  3. Under the FTP option select Transfer. From the Transfer tab under Directory Listing Options enable the options "[-a] Show All Files" & "[-L] Resolve Links".

You can then check the folder again for hidden files. If this does not turn up anything, contact your host, they will remove the folder for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.