Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using XFCE 4.6.1 (Xubuntu distribution) on my laptop and main computer; the settings are approximately the same. so far for the intro.

What I'm experiencing is that when going to the screen edge over the task bar on the laptop, the button under the mouse is active. On the main machine however, having the mouse on the screen edge, the button below it doesn't react at all! Only if I move the pointer towards the center a bit, the hover highlight starts and the button becomes clickable.

I've tried to change the panel size, desktop theme and a few other settings, but none seems to cure that problem. Is there something that causes this problem? (Googling also seems to give no results)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

It appears I've figured it out on my own... It's a "feature" of compiz. The solution is explained here:

http://lists.compiz-fusion.org/pipermail/dev/2009-January/001146.html

Compiz uses small, 2 pixels wide windows to detect edge actions. Unfortunately, it's not possible to pass the enter/leave/motion events to the window beneath with the X infrastructure as it stands :-/

You probably want to disable the top and/or bottom edges in the wall plugin (under "Key bindings" -> "Edge flipping").

I don't depend on that edge flipping feature very much, so this fixes it for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.