Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm writing a report on developing EJBs in Jdeveloper and every time i type "IDE" my laptop beeps twice in quick succesion.

Actually, whilst typing this I've worked out that any combination of shift plus two adjacent keys, one from the row that starts qwerty and one from the row that starts asdfg will beep.

It's really quite annoying. It's a hp laptop.

Anyone know how I can make it stop?

share|improve this question

2 Answers 2

I suspect that you are triggering three-key rolllover.

IIRC, the keyboard sends the BIOS a key-down and a key-up message for every key you press, including shift, alt and "windows" keys. The BIOS converts these into actual characters which are then buffered ready for the program to use.

Some keyboards/laptops and BIOSes will notise if you press a second letter key before releasing the first, or otherwise press multuiple keys in error. Many won't.

There may be a three-key rollover entry in your BIOS settings that you can change.

Failing that, you will have to type slower, and/or turn the volume of your beep down. (I can do that on my HP laptop).

share|improve this answer
    
Just had a look in the bios, but there are few options there for anything, let alone a three-key rollover. Is your beep volume in the bios as well or is there another way of turning it down/off? –  blank Jan 6 '10 at 9:26

My computer also has this problem, I can't find a permanent fix, but if you hold down the shift key for approximately 12 beeps it should go away until you restart your computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.