Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've built a new computer and installed a new copy of Windows 7. Although this desktop is way superior than the previous one in terms of hardware specs, the OS just completely freezes for about 15-30 seconds every few minutes, then the hard drive kicks in (I hear it working) and everything back to normal.

I'm running Windows 7 Ultimate (64-bit) with 8 GBs of DDR3 RAM and an Intel i7 processor. In theory it should run as smooth as silk, but it's not. The OS is completely encrypted with TrueCrypt, but not sure if that's the cause of the issue.

Note that during the freeze-ups the CPU level is very low and only 1.80 GB of memory is used.

How can I troubleshoot this kind of issue?

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

As it is a new machine, just to rule it out, I would start by doing a memory test using memtest86+.

If problems - change memory, if not read on!

If the system is brand new and you do not have a lot on it, I would try reinstalling without Truecrypt just to rule it out and if everything is fine, do it again with Truecrypt just to rule it out.

After this, if you are still having problems, check all your components for damage and make sure that they are connected properly.

share|improve this answer
1  
I would say to check the components for damage before reinstalling without truecrypt, but that's just my preference. –  Joshua Nurczyk Jan 6 '10 at 19:31
    
Good point - However, the thing is, I never know if people self build or pre buy and I like to give advise with hardware tinkering being last priority.... but agreed that this is probably the problem. –  William Hilsum Jan 6 '10 at 19:58
add comment

There is a thread on Truecrypt.org about this http://forums.truecrypt.org/viewtopic.php?t=17643 Basically, they suggest three things:

This problem is caused by the C1E Halt State ("Enhanced Halt State") of some processors.

  1. Disable the C1E Halt State in your BIOS and the problem is gone. There is a Bug in the C1E implementation on recent AMD processors, which has an effect on IO performance. You will also notice faster transfer speeds with USB and gigabit LAN.

  2. Disable the power down control for memory DIMMs ("allows DIMMs to enter power down mode by deasserting the clock enable signal when DIMMs are not in use").

  3. Upgrade BIOS firmware to the latest version

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.