Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just istalled the latest debian with a graphical desktop environment and for some reason i cant install any thing.

for example

apt-get install subversion - cannot be found. apt-get install synaptic - cannot be found. i run apt-get update laready apt-get install firefox-3.5 - will result the following output.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  firefox-3.5-gnome-support latex-xft-fonts
Recommended packages:
  ubufox
The following NEW packages will be installed:
  firefox-3.5
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0B/942kB of archives.
After this operation, 3,731kB of additional disk space will be used.
(Reading database ... 64746 files and directories currently installed.)
Unpacking firefox-3.5 (from .../firefox-3.5_3.5.8~hg20091224r26704+nobinonly-0ubuntu2~umd1~jaunty_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/firefox-3.5_3.5.8~hg20091224r26704+nobinonly-0ubuntu2~umd1~jaunty_i386.deb (--unpack):
 trying to overwrite '/usr/bin/firefox', which is also in package iceweasel 0:3.5.5-1
Processing triggers for menu ...
Errors were encountered while processing:
 /var/cache/apt/archives/firefox-3.5_3.5.8~hg20091224r26704+nobinonly-0ubuntu2~umd1~jaunty_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


What do you think went wrong. I did that already in the past and i did not experienced such problems, could it be because the debian is under VirtualBox? Thanks

share|improve this question

migrated from serverfault.com Jan 6 '10 at 10:16

This question came from our site for professional system and network administrators.

2 Answers 2

It looks like you're trying to use the Ubuntu repositories in Debian... Debian doesn't have firefox packages, they've been renamed into iceweasel, and the fact that the firefox-3.5 package recommends ubufox is a strong hint that you're using Ubuntu repositories.

Can you show your sources.list ?

Edit:

After seeing your sources.list, you have two options:

  • Reinstall your machine on Ubuntu if you want to benefit from the PPAs
  • Stop using the PPAs if you want to stay on Debian, and find another source for firefox-3.5 (or probably iceweasel-3.5 instead).
share|improve this answer
    
What about subversion, dont you think it is strange? Thanks <pre> # # deb cdrom:[Debian GNU/Linux testing Squeeze - Official Snapshot i386 CD Binary-1 20091221-04:49]/ squeeze main deb cdrom:[Debian GNU/Linux testing Squeeze - Official Snapshot i386 CD Binary-1 20091221-04:49]/ squeeze main deb security.debian.org squeeze/updates main deb-src security.debian.org squeeze/updates main deb ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main deb-src ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu jaunty main </pre> –  fatnjazzy Dec 27 '09 at 7:42
2  
You're using (at least) one jaunty PPA. These are repositories for Ubuntu, which are likely to conflict with your Debian install, or even break it. If you want to use Ubuntu packages, you should install Ubuntu instead of Debian. –  ℝaphink Dec 27 '09 at 13:47

You have a conflict about the file /usr/bin/firefox.

In Debian, for legal reason, firefox had be unbranded to iceweasel (which is already installed in version 3.5 and provide the /usr/bin/firefox to offer filename level compatibility). If you really want to install your package firefox 3.5, the easiest is to remove first the iceweasel package.

share|improve this answer
1  
No, this is a really bad idea. He's trying to install firefox compiled for Ubuntu Jaunty on his Debian machine. Forcing this will break dependencies in apt, and it will be hard to fix afterwards. –  ℝaphink Dec 27 '09 at 13:48
2  
Recommending any --force option is an incredibly bad idea -- if you don't know enough to use it on your own, then you definitely don't know enough to use it responsibly. –  womble Dec 27 '09 at 22:43
    
It seems like I didn't emphasized enough on the removal of iceweasel as the preferred solution. As I stated, if there is a good reason why you can't or don't want to remove the former package, you have to use --force. I never said that's because "you can" that "you should". –  Zeograd Dec 27 '09 at 23:04
    
Concerning the dependency break, you are wrong. As I first proposed, --force-overwrite, it will never break any dependency ! It allows for packages claiming the same file to be both installed (the later owning the common files, of course), --force-all can break dependencies but in this case, he's trying to install 2 applications based on the same upstream, with different packaging and which only share one binary path. How installing both could possibly break dependencies ? –  Zeograd Dec 27 '09 at 23:10
1  
That's right, --force-overwrite won't break dependencies. However, the user already mixed up jaunty entries with squeeze in his sources.list, which indicates that he might not entirely understand the consequences of doing so. Forcing to install Ubuntu packages in Debian might just result in a segfault. The previous (working) binary will have been overwritten, and the user might not know how to reinstall it cleanly. –  ℝaphink Dec 28 '09 at 10:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.