Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running Windows 7 on an Acer Aspire M7720 with three internal SATA drives; drive #2 and #3 are on a removable HDD rack.

Drive #3 (on the second removable HDD rack) shows up as removable device in the system tray. If I take drive #3 and put it in the first rack, it shows up as an internal drive. If I put any other drive in the second removable rack, that drive is also shown as removable device.

I would like to fix that so that the drive in the second removable rack also is listed as internal drive. Since this seems to be independent of the actual drive in the rack, I checked the BIOS, but that third SATA port uses the same configuration as the second rack.

So far, I could not find a solution for this problem (it's really more an annoyance than a problem), any ideas are welcome.

share|improve this question
add comment

3 Answers 3

up vote 7 down vote accepted

This happens if the SATA controller is set to AHCI mode. AHCI supports hot swapping, and because of this, you can ask Windows to "Safely Remove" an internal hard disk, disconnecting it from the OS and replace it without having to power down the system.

share|improve this answer
    
Does it work even if the internal drive holds system partition? –  liori Jan 6 '10 at 23:35
    
@liori - Yes, although Windows will prevent the drive from being unmounted as the files are in use. –  Sathya Jan 6 '10 at 23:44
add comment

Related, to stop the hard disk from showing up as removable on windows XP, the answer from here (modifying the registry), worked for me:

Real removable devices (USB) still show up as normal, but it removes the internal SATA controller drives from being displayed.

For nForce chipsets, you can add the following to registry: In HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ nvata, add DWORD DisableRemovable, set to 1.

Reboot.

64-bit systems use nvata64. Some chipsets might use nvatabus instead.

This doesn't work with VIA chipsets (driver vide or videX64), the only option I've found for them is to use older drivers that don't support SATA hotplug.

share|improve this answer
    
I have no clue why my answer got downvoted (apart from that it applies to Windows XP). Still, I leave it here in the hope somebody finds it useful. –  Rabarberski Apr 4 '11 at 14:00
add comment

This usually indicates that not all required drivers are installed on a system. For example, on Intel chipset you need to install Rapid Storage Technology driver. After that, hard drives are identified correctly as not removable.

Be aware however that this driver installation procedure can trigger Re-Activation for some software applications.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.