Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Asking this on both serverfault and superuser.

When attempting to network boot RHEL 5.4 on an old ia64 machine I get the following error :

alt text

So I've basically followed the tutorial here : http://www-uxsup.csx.cam.ac.uk/pub/doc/suse/sles9/adminguide-sles9/ch04s03.html

DHCPD,TFTPD etc are already setup and working with standard x86 PXE clients.

I've unpacked the boot.img file into /tftpboot/ia64/ and passed the path to the elilo.efi file via DHCP with the filename ""; option.

Changing this filename generates a PXE file not found error (see below). So I assume that PXE has found the file...

enter image description here

The only thing wrong I can find in the logs is :

Jan 6 19:49:31 dhcphost in.tftpd[31379]: tftp: client does not accept options

Any ideas? I'm sure I hit a problem like this a few years ago but I can't remember the fix.

share|improve this question
add comment

closed as too localized by random Feb 11 '12 at 0:56

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

Nice question - However, you may have better luck on Serverfault, but I will do my best to help you here!

I messed around with DHCP/BootP/PXE a while ago. The easiest thing I can recommend you do is to set up a virtual machine and install TftpD as you can configure it to be verbose and diagnose problems.

From that screen, it looks like as it says, it simply cannot find the file - try messing around with forward slashes in the name (at the start), and keeping it simple, for example try just elilo.efi in the path and place the file in the root tftp directory.

When it comes to diagnosing things like this, you really want to take it to basics and get complicated when you know it is working.

share|improve this answer
    
Hey thanks for the reply, I'll update/reword the question in the morning (GMT) with more info etc –  Lee Jan 6 '10 at 21:54
    
Stupid me - I missed the top line!... Will copy my answer to serverfault as well so it can be criticised by others pros there and get feedback! –  William Hilsum Jan 6 '10 at 21:56
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.