Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to install Apache HTTP Server v2.2.14 on a machine recently upgraded to Windows 7. It worked fine under Windows XP, but when I go to install this in Windows 7, the install script appears to hang. In the install wizard dialog it states:

Installing Apache HTTP Server 2.2.14
The program features you selected are being installed.

Please wait while the Installation Wizard installs Apache HTTP Server 2.2.14. This may take several minutes.

Status:

<progress bar with thin sliver at left edge that makes no progress>

I tried with and without openSSL support, both fail the same way.

Is this known to work on Windows 7? If so, how do I debug what is going wrong?

share|improve this question

4 Answers 4

Not sure if this is an issue with compatability but this tutorial shows you how to install it on Windows 8

share|improve this answer
    
That tutorial only mentions: "Run the downloaded installer" for the step that I am explaining above that fails. –  WilliamKF Jan 7 '10 at 1:38
    
Perhaps you've made a typo? Windows 8 –  Moshe Jan 7 '10 at 3:49
    
I want Windows 8! –  John T Jan 7 '10 at 4:05

Are you attempting to install Apache on a version of Windows 7 with BranchCache enabled?

If BranchCache is enabled, port 80 is used by Windows.

share|improve this answer
    
Seems strange that the install would need port 80 access. Is BranchCache enabled by default on Windows 7? I have made no changes that I am aware of to how it is set by the install of Windows 7 by default. –  WilliamKF Jan 7 '10 at 3:39
    
Branchcache is only available on Enterprise/Ultimate for Windows 7. You can use netstat -a or a program like TcpView from SysInternals to determine if anything is locally listening on port 80. –  Darren Hall Jan 7 '10 at 3:55
up vote 1 down vote accepted

Okay, Windows 7 is not impressing me. I figured out the issue. There was a dialog hidden underneath the install wizard asking if I really wanted to run the install because it was from an unknown source. I would expect any such dialog to be raised above not below. Only by accident did I discover it was lying in wait hidden below.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.