Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In FF 3.5.7 on Vista I am getting garbled text like below on some web pages.

screenshot

The obvious answer is to go to View > Character Encodings > then select UTF-8.

However, it turns out I am already using UTF-8 encoding and this is still happening.

Any help would be greatly appreciated, thanks ahead of time.

share|improve this question
1  
Is it just Firefox? –  Zurahn Jan 7 '10 at 4:09
    
Yes, it looks fine in both Chrome and IE... weird. –  user23911 Jan 7 '10 at 4:43
    
+1 because I've had this problem before as well. Unfortunately I don't remember how I fixed it. –  Sasha Chedygov Jan 7 '10 at 5:58

3 Answers 3

up vote 1 down vote accepted

Go to about:config and set browser.display.auto_quality_min_font_size to something improbably-high to turn it off.

I've had this problem with fonts I naively copied-and-pasted from other systems into Windows (eg, really old Mac fonts), and only on Firefox with this setting in effect.

share|improve this answer
    
Thank you sooo much! This solved the problem. –  user23911 Jan 10 '10 at 20:41

Try going to...

Tools > Options > Content > Languages

Then make sure everything is correct there.

If that doesn't work try putting it into safe mode then disable all of the plugins to make sure it's not one of them.

Heres some details on how to get Firefox into safe mode

share|improve this answer
    
Unfortunately this didn't solve anything. –  user23911 Jan 7 '10 at 6:59

I surfed to github.com using FF 3.5.7 and didn't get this problem.
(If you have an example of a problematic URL, please post.)

I would suggest uninstalling FF using revo, then reinstalling from scratch.
Try then the display before installing any add-ons.
Then install the add-ons in steps, checking the problem every step.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.