Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Update 5 - SFC /SCANNOW

This update is important enough to put at the top of the question!

As suggested by @harrymc, I tried running SFC /SCANNOW at an administrative command prompt. The resulting CBS.LOG file has some very interesting entries toward the bottom:

Hashes for file member \SystemRoot\WinSxS\x86_microsoft-windows-ieframe.resources_31bf3856ad364e35_8.0.7600.16385_en-us_aa56e58ba603e4d6\ieframe.dll.mui do not match actual file [l:30{15}]"ieframe.dll.mui" : Found: {l:32 b:DdY39ZR8qqIjw6lQcL2Xvbjw0T2ScyWz76yzlq0sf5w=} Expected: {l:32 b:3MM8XlEFjOgqH6G7JUOh1CYW8IVRe8Nnt/64UpCD2l0=}

(snip half-a-dozen more lines like that)

Could not reproject corrupted file [ml:60{30},l:58{29}]"\??\C:\Windows\SysWOW64\en-US"[l:30{15}]"ieframe.dll.mui"; source file in store is also corrupted

So it seems that the slipstreamed version of Windows 7 installed by the computer store was corrupt in some way. A repair install from my genuine DVD will no doubt fix the problem, but I might hold off doing that for a while and see if a future Windows Update pulls down newer versions of the problem DLLs and fixes it for me.


Hi gang,

I'm posting from my new PC, which is running a clean install of Windows 7 Home Premium x64.

When I run IE8 and click the "New Tab" icon, I'm presented with a corrupt version of the standard "New Tab" page:

alt text

If I run the x64 version of Internet Explorer, the "New Tab" page looks just fine.

Any ideas what could cause this sort of corruption, and how to fix it?


Update 1 - No Add-Ons

I have tried running IE8 32-bit in "No Add-ons" mode, but the problem persists, so I'm sure it's not related to an add-on that IE is loading. Heck, it was doing this before I installed anything, so it can't be anything to do with an add-on.

Update 2 - A Corrupt Accelerator?

A colleague has suggested that it could be a corrupt "Accelerator" loaded in IE8. Now, when this started happening, I had only just been through the initial "Welcome to IE8" wizard, but I did ask it to give me a list of search providers to choose from instead of using Bing, and I installed the Google search provider from that list. I'm wondering now whether that provider was corrupt in some way.

The list of search providers that IE8 shows you when you first run it is not the same list as when you click "Find More Providers" after the fact, so perhaps there's an incompatibility with the Google search provider on that list, and the "Google Search Suggestions" provider you see on the ieaddons.com. I will try uninstalling the Google search provider later today too.

Update 3

Ok, so removing the Google search provider had no effect, and nor did deleting IE's temporary files. Per @harrymc's suggestion I have uploaded a zip file of the page to http://madprops.org/mabster/newtabcorrupt.zip. With any luck someone can diagnose this problem and save me from having to pave the PC (or live with it)!

Update 4 - Reinstalling IE8

At @harrymc's request I tried unchecking Internet Explorer in the "Turn Windows Features On and Off" dialog and rebooting, then checking it again and rebooting once more (effectively reinstalling IE8). No joy - the New Tab page is still corrupt.

share|improve this question
1  
Not an answer to your problem, but perhaps switch to a better browser? Firefox would be my choice and if you really need to see pages as rendered in IE got the IE Tab add-on to allow you to switch –  ianfuture Jan 7 '10 at 11:38
    
Yeah I knew when I posted it that I'd run the risk of getting responses like that. :) I really want to solve this one in case it's a symtpom of a deeper problem. –  Matt Hamilton Jan 7 '10 at 11:49
4  
Flaming IE isn't going to help people. This is a very strange problem. –  Nick Josevski Jan 7 '10 at 12:06
    
And the IE Tab add-on basically shows IE within Firefox, so won't solve any issues either? –  Arjan Jan 8 '10 at 9:34
    
Not interested in switching browsers, I'm interested in getting to the bottom of this problem. I'd like a solution, not a workaround. –  Matt Hamilton Jan 8 '10 at 9:37
add comment

2 Answers

up vote 2 down vote accepted

There are two registry locations, one for 64-bit and the other for 32-bit.

64-bit is:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\AboutURLs  

32-bit is:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\AboutURLs

I believe that both are supposed to contain an entry named Tabs that contains the value
res://ieframe.dll/tabswelcome.htm; check that the 32-bit entry is correct.

Also, in IE8 (32-bit) make sure that under Tabs settings and under the category "When a new tab is opened, open:" you have it set for "The new tab page".

share|improve this answer
    
Yep, the registry entries are correct, and the page in the screenshot above is definitely that URI. –  Matt Hamilton Jan 7 '10 at 19:47
    
What happens if you enter "res://ieframe.dll/tabswelcome.htm" at the address-bar of IE? –  harrymc Jan 7 '10 at 20:09
    
Yep, same problem. –  Matt Hamilton Jan 7 '10 at 20:16
    
That dll apparently generates the page in the temporary IE directory. Can you clean all temporary content in IE (cookies not necessary), and afterward save the page as "webpage, complete". Zip up all files and the sub directory, and post it somewhere that I can download and examine? –  harrymc Jan 7 '10 at 20:32
1  
I would first do some scans with Avast, MBAM and Spybot S&D. The next step is probably "sfc /scannow" in administrator's cmd. Afterward we arrive at a repair installation (if you have a real Win7 cd). And finally we do a fresh installation. You should consider where you wish to stop, meaning when is the cure worse than the problem ... –  harrymc Jan 8 '10 at 17:12
show 7 more comments
  1. Click Start > Run and type regedit.exe.

  2. Navigate to the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\TabbedBrowsing
    
  3. Create a REG_DWORD value named ShowTabsWelcome.

  4. Leave the Value data for ShowTabsWelcome as 0.

  5. Quit the Registry Editor.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.