Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Well in short i messed up with some folder's right click>Proprieties>Security Tab. Those folders are in an external HDD. The outcome of such a thing like (like messing with stuff you don't fully understand) is that now, when the HDD is connected to another PC, those same folders become accessible only after providing the administrator password (a pop up message saying: "you don't currently have permission to access this folder" is shown for the folders and their sub-folders and their respective contents). Is it there a way to restore those folders to their normal state where they can be accessed/watched by anyone with out any permissions whatsoever? (and the files inside them too of course), like any normal windows folder?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

Set the owner and permissions to "Everyone". You might have to go into the properties twice: first for ownership, then second for permissions.

  • Right-click > Properties > Security (tab)
  • Click Advanced > Owner (tab) > Edit
  • Click Other users or groups > type Everyone > click OK
  • Check Replace owner on subcontainers and objects (make sure Everyone is selected)
  • Click OK

You should be back at the Advanced Security Settings for Folder window. Only do this next step if the folder doesn't show "Everyone" in the list.

  • Click Permissions (tab) > Change Permissions
  • Remove all entries in the list
  • Click Add and add Everyone like before
  • Click on the Allow checkbox next to Full control and it will populate everything for you
  • Check the Apply these permissions to objects and / or containers within this container only
  • Click OK
  • Click OK
  • Click OK
  • Click OK
share|improve this answer
    
Ok...but how do i accomplish that?. Sure, right click>Properties>Security... and after that i'm lost (sure i could guess, but doing that is what got me here in the first place...) –  Fellknight Jan 7 '10 at 22:10
    
I've edited my answer to tell you how to do this. –  user3463 Jan 8 '10 at 8:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.