Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I accidentally disabled the Bluetooth on Mac OS. I can't enable it because my Bluetooth based keyboard and mouse are now disabled.

I found a USB based keyboard I can use, so how can I enable Bluetooth just using my keyboard?

Is there a command line way or shortcut I can use?

share|improve this question
I can just imagine the :facepalm: when you realized what happened. Hope someone has the right answer for you. :) – JMD Jan 7 '10 at 19:47
what if my keyboard is also bluetooth ? – john Smith Aug 6 '14 at 10:13

13 Answers 13

Here's a sequence that worked for me (OS X 10.6.7) when I had the same issue.

  1. Press Space to activate Spotlight.

  2. Type "bluetooth", choose the 'Bluetooth File Exchange' application, and press Return.

  3. Bluetooth File Exchange will prompt to enable the bluetooth hardware, press Return.

  4. Bluetooth is now enabled and you can quit Bluetooth File Exchange.

share|improve this answer
This worked better for me, as I have the function keys set to control playback, and Control+F7 wasn't enabling full keyboard access... Thanks! – geerlingguy Jun 22 '11 at 14:31
worked perfectly. thanks – mbrownnyc Sep 1 '11 at 2:39
This worked well for me because the On checkbox in the Bluetooth preferences pane was not selectable :-( OS X Lion – Bennett Dill Feb 1 '12 at 17:18
This worked way better for me than fideli's answer which got me all the way to bluetooth settings but I could not tab to the on check box. This was also lot faster and easier. – JD Isaacks Jan 16 '13 at 15:19
Elegant and functional — this was an awesome answer. – ehfeng Apr 16 '14 at 20:34
  1. +Tab until you get to the Finder.
  2. ++G to bring up the Go To dialog: type in /Applications.
  3. Just type the letters "sys" and your highlight should be over "System Preferences". Press +O to open it.
  4. In System Preferences, the cursor should be in the search field. Just type in "bluetooth" and press Return. Now you're in the Bluetooth preferences.
  5. Press Tab, and there should be a faint highlight on the "On" checkbox.
  6. Press Space, and that should turn it on.

If you happen to have Quicksilver installed, invoke System Preferences from there and go directly to step 4 above. Or without Quicksilver press +Space to activate Spotlight, type "bluetooth" and go directly to the Bluetooth preference pane, and step 5 above.

If you don't have a Command key on the keyboard, then hit Ctrl+F2 to activate the Apple menu, press and go to System Preferences and continue at step 4 above.

If in Step 5 pressing Tab does not navigate through all inputs, then press Ctrl+F7 to activate Full Keyboard Access. When done, press Ctrl+F7 again to disable it.

share|improve this answer
1-3 can be replaced with: ⌘-space; type "sys"; hit enter. (⌘-space launches Spotlight.) – Jonik Mar 6 '10 at 19:35
This is a great answer! – Josh Mar 10 '10 at 20:09
Can't highlight the On checkbox with tabbing... change in snow leopard? – mbrownnyc Sep 1 '11 at 2:39
The last paragraph was the one I needed, thanks! – MikeSchinkel Dec 4 '11 at 6:33
Thanks a lot. The Ctrl-F7 tip saved my life. – Rodrigo Pinho Pereira de Souza Jan 1 '12 at 20:03

I've been using blueutil occasionally - seems to work. It's free and comes with the source code.


Print bluetooth status
blueutil status

Switch bluetooth on
blueutil on

Switch bluetooth off
blueutil off

share|improve this answer
I installed this via brew and the on command was blueutil power 1 – Nick May 21 '15 at 20:56

I wanted to mention a little known feature of the OS:

If you reboot and unplug the keyboard, the OS will automatically enable Bluetooth and start looking for BT keyboards and mice. From Apple's official documentation:

  1. Turn on your Mac.
  2. If no USB mouse is detected, the Mac will power up to the Bluetooth trackpad or mouse setup assistant. The screen should alternate between an image of the trackpad and one of the mouse, as below.

However, this is apparently controlled by a Bluetooth setting which might be disabled:

Bluetooth Setup Assistant Settings

If this setting has been disabled by the user (it is enabled by default) then this method will not work.If these options have been disabled, you can re-enable them using the terminal commands:

sudo defaults write /Library/Preferences/ BluetoothAutoSeekKeyboard '1'
sudo defaults write /Library/Preferences/ BluetoothAutoSeekPointingDevice '1'

(However you might need to SSH in to do that, a which point one of the other answers might be better)

share|improve this answer
This is arguably better than any of the other answers :). Very little technical knowledge required. – msouth Dec 22 '14 at 16:25
But what if you don't have a wired keyboard or mouse - only Bluetooth ones? As far as I can tell the computer won't enable Bluetooth even with a reboot. – Ed Avis Mar 23 '15 at 18:19
I believe that the login screen will automatically enable Bluetooth if there's no HID devices connected. I'll look for a reference tonight – Josh Mar 23 '15 at 18:20
Following some instructions elsewhere, I unplugged everything from the iMac, plugged back just the power cord, and then switched it on. That worked (after a short delay at the login screen when it appeared not to). – Ed Avis Mar 24 '15 at 9:46

This method required the bluetooth menu bar status icon to show and used AppleScript GUI scripting (requires System Preferences » Universal Access » Support for assistive devices IIRC):

tell application "System Events"
    tell process "SystemUIServer"
        tell (menu bar item 1 of menu bar 1 whose description is "bluetooth")
            click menu 1's second menu item
        end tell
    end tell
end tell

Call from command line using osascript:

osascript -e 'tell application "System Events" to tell process "SystemUIServer" to tell (menu bar item 1 of menu bar 1 whose description is "bluetooth") to {click, click (menu item 2 of menu 1)}'

Do not edit this post. I don't care if you don't like the scroll bar. It's easier to select by triple-clicking this way.

Alternatively, you can launch System Preferences and click the checkbox:

tell application "System Preferences"
    set current pane to pane id ""
    tell application "System Events"
        tell process "System Preferences"
            click checkbox "On" of window "Bluetooth"
        end tell
    end tell
end tell

While a GUI process launches, it isn't visible except for the Dock icon.

share|improve this answer
For Yosemite 10.10.3 I had to replace 'click checkbox "On" of window "Bluetooth"' with 'click button "Turn Bluetooth Off" of window "Bluetooth"' – JS. Jul 1 '15 at 18:08
  • Press Space, write "bluetooth".
  • Press the following combination: FnF7. A light blue frame appears arround the activate box.
  • Press spacebar, finished!
share|improve this answer
The sequence Fn⌃F7 activates full keyboard access; once you've turned it on you'll be able to simply tab between the control elements in the window. – Josh Ourisman Oct 31 '12 at 15:17

Here is a faster way which I just did on Lion:

  1. Command + Spacebar to start spotlight
  2. type "bluetooth"
  3. Select "Bluetooth File Exchange"
  4. This will trigger a warning that bluetooth is disabled, the enable button should be highlighted so all you need to do now is press return
share|improve this answer
Worked on Mavericks, too! – Dennis Wurster Jun 13 '14 at 13:41

Simply turn on your Mac. press F then type "bluetooth" then press until you reach the "bluetooth" icon.

Then O and to enable Bluetooth! That's the easiest way to make it!

share|improve this answer

Use Alfred and the Bluetooth workflow


Bluetooth Toggle

enter image description here

share|improve this answer

In my case, the CTRL+F8 method (posted by PIXIT, down below) is exactly what I need. Here's why: When I change the battery on my Magic Mouse, the computer often fails to reconnect the mouse. The other answers here talk about turning Bluetooth on or off. My Bluetooth is on, but I need to specifically activate the Mouse connection. Going through the status bar with the arrows lets me go down through the menu to My Mouse, and sideways to Connect.

(OS 10.10.3)

share|improve this answer

If you are using a apply keyboard (wired) - just press Option+F8. If you are using a Windows keyboard (wired) - just press Ctrl+F8.

share|improve this answer

If you are attempting to reinstall OSX from boot media, and your Bluetooth wasn't enabled at the start (still an issue with Mountain Lion Recovery media), Ctrl + fn + F2 gets you to the menus at the top (as described many other places), which contain other useful utilities, like Terminal.

I'm lucky that my mouse was immediately recognized (I'm sure there's ways to delve further once this has been stirred), allowing me to click things which were otherwise completely stymied (like "install"), through one short terminal command: blued . The Bluetooth daemon kicked up and gave MAC addresses for probably two devices I have currently battery powered, and around. Hope that helps others, rather than forcing us all to get/keep USB wired mice around, dust free, and in workable condition.

Other extraneous USB pointing devices failed where this method succeeded for me. The computer I am working with has a fully powered and interactive Wacom Bamboo tablet-- this doesn't get anyone anywhere since I'm sure drivers aren't included/loaded at the point I found myself.

share|improve this answer

ctrl+F8 activates the status menu.(upper right corner) If bluetooth button is enabled in the status menu, you can select the bluetooth-menu-option using arrow-keys and return-key to activate bluetooth

share|improve this answer
This sounds like a Windows keyboard shortcut instead of a OS X shortcut. – Ramhound Oct 7 '14 at 18:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.