Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Excel 2007, when I click a hyperlink, it opens in IE. I'm running XP Professional SP3.

Firefox is set as my default browser. Links in Word and Outlook open in Firefox. But Excel opens them in IE. Anyone know how to fix it?

Edit: Process Explorer shows the command line for IE to be

"C:\Program Files\Internet Explorer\IEXPLORE.EXE" -Embedding

share|improve this question
    
Fix it? It's not really broken. –  pavium Jan 7 '10 at 20:28
1  
How is it not broken? It's opening links in a browser other than my default browser. Thanks so much for the helpful comment. –  skypecakes Jan 7 '10 at 21:00
1  
Not a direct answer, and not very likely, but it might be somehow related to "Microsoft Office Protocol Discovery" See superuser.com/questions/41935/… –  Arjan Jan 7 '10 at 21:19
1  
And though I doubt it matters: are these hyperlinks created using the HYPERLINK formula, or links that are made clickable automatically just because Office recognises them? –  Arjan Jan 7 '10 at 21:21
    
Using HYPERLINK formula or Developer Toolbar-> Insert Hyperlink. I tried pasting text that contained a hyperlink and Excel didn't linkify it. I will look into DDE when I get a chance to see if it leads anywhere. Thanks for the link! –  skypecakes Jan 7 '10 at 23:41

3 Answers 3

I just checked here with my Excel 2007, Firefox, and Windows XP Pro SP3, and Excel opened a link in Firefox, which is my default browser.

I would try "resetting" your default browser in the system by setting the default to IE and back to Firefox.

In Internet Explorer:

  • Go to "Tools" and then "Internet Options"
  • Click on the "Programs" tab
  • Click the "Make default" button
  • Click OK

Press Win+R to open the Run box, and type in a website (ie, www.google.com). It should open in Internet Explorer.

In Firefox:

  • Go to "Tools" and then "Options"
  • Click on the "Advanced" tab (on the far right)
  • Click on the "General" tab
  • Click the "Check Now" button
    • If Firefox is not the default browser, which it shouldn't be right now, it should ask if you want to set Firefox as your default browser. Click Yes

Go back to the Run box (or press Win+R again) and type in a website (ie, www.google.com). This time, it should open in Firefox.

Check Excel and see if it's opening it in the right browser now.

share|improve this answer
    
Nope, still happening. Thanks for the suggestion. –  skypecakes Jan 7 '10 at 21:00
    
And thanks for letting me know it works for you. Now at least I know that it's possible for it to work correctly! –  skypecakes Jan 7 '10 at 21:07

Three fairly easy solutions here: http://www.consumingexperience.com/2008/02/make-links-in-word-excel-etc-open-in.html

share|improve this answer
    
Mike, thanks for contributing, but in Superuser we like people to summarize solutions, not just link them. –  Isaac Rabinovitch Nov 23 '12 at 22:23

Use this method, it launch link in default browser:

Dim something as link

ThisWorkbook.FollowHyperlink link

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.