Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a basic file server at my work (a workgroup, not a domain), and am new to sharing beyond windows simple sharing. The "server" computer is running XP Pro, and all of the other computers are running XP Home. The catch is that I would like certain folders to only be accessible to certain computers and/or users. I've turned off simple file sharing already, and the basics of setting up permissions seems easy enough. The problem I'm having is that I'm only able to add users that are on the XP Pro machine. I can't add a location, which I think is what I need to do. Is that right? If I can't do it, should I just add a bunch of user accounts on the XP Pro machine and go from there?

Thanks for any help!

Edit: I've tried adding user accounts to the XP Pro machine, but still can't figure out how to connect with the XP Home machines. I've tried all sorts of ways to change the user name and password but to no avail. Any ideas?

share|improve this question
add comment

3 Answers

up vote 0 down vote accepted

How are you connecting to the "server" computer? Are you going to \server\share, or are you mapping a drive letter?

In either case, try the following command on the client computer from the command line (start>run>type "cmd", press enter):

net use * /delete


That should remove all connections you have to the server that may have bad credentials attached.

Good luck!

share|improve this answer
    
I have tried going directly to the share and mapping it. Neither way works, even after trying the command you suggested. It simply says access is denied. On the XP Pro side I have the user set up with full permissions. Anything else I can try? –  bikefixxer Jan 8 '10 at 18:02
    
Okay, I figured it out. Since the command you suggested was key in the solution I'm marking this as the answer, but I'm also posting what I needed to make it work. The problem was really stupid and simple. When I set up the sharing permissions, I set up the user I wanted with full permissions and then selected "Deny" on every option for the user "Everyone". No wonder it didn't work right? So I removed the user "Everyone" and now it works exactly how I wanted it to. Thanks for your help!!! –  bikefixxer Jan 8 '10 at 18:40
add comment

Since you are trying to add some users to be able to access the share and not others from the same workgroup, you will need to add them to the XP Pro system and then on the share, assign them rights to the share. XP will use the transfered credentials to allow/deny access.

If it is a case where some computers will access this system and totally not others, then you can have some one one workgroup and the others on another - different workgroup name - and use simple sharing.

share|improve this answer
    
Thank you for responding. However, I'm not sure how to accomplish what you suggest. When I add a user to the Pro system, and then add them in the permissions folder, it displays the user name as PROCOMPUTER\USERNAME. Even though the user name and password is the same as a Home computer, it won't connect because it says I don't have permission. How do I make the credentials transfer? –  bikefixxer Jan 8 '10 at 0:41
add comment

Let me see if I'm understanding the situation clearly:

  • You have an XP Pro machine with several file shares.
  • You have created user accounts on the XP Pro machine that match the usernames of the xp home machines
  • Each share's permissions have been set to allow the appropriate users of the XP Pro machine (you will never be able to add users from another machine unless you join a domain... I think).
  • You are unable to authenticate from the XP Home machines to the XP Pro machines

Are you editing the permissions in the Security tab or the Sharing tab? Security tab is for local access (sitting in front of the machine), and is independent from the permissions on the sharing tab.

I'm betting that this is where the permissions breakdown is occurring. The two different settings tabs can be confusing at first.

Are you mapping drives on the XP Home machines to the shares?

share|improve this answer
    
The way you explained the situation is spot on. I am trying to map the drive but it still won't work. I've set up the user with full access on the sharing tab and security tab. Still no go. I tried this with a Windows 7 Ultimate machine and it worked fine. What is different with XP Pro that I'm doing wrong? –  bikefixxer Jan 8 '10 at 18:06
    
Have you disabled the built-in firewall in XP, or alternatively, enabled file sharing in the Firewall settings? –  jonfhancock Jan 8 '10 at 19:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.