Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my laptop I have a 250gb hd that's separated up in 2 drives:

C: which is 64gb D: which is the rest.

I'm logging on my laptop as a domain user which is administrator on the laptop. However, when I want to save files through my browser on the D: drive i always receive an access denied. Same thing when I want to attach a vhd in hyper v that's on the D: drive. Also access denied. However no problems at all when using the C: drives.

So there is something weird going on, on that D: drive. Because I can move files to the D: drive using explorer just fine.

Any recommendations as what to do to make it use the exact same permissions as on the C: drive... This behavior was not present in Win7 or Vista and is something new to win2008 r2.

Thank you in advance.

share|improve this question
    
I suspect this is a policy that needs to be disabled. –  user19353 Jan 8 '10 at 12:00

2 Answers 2

up vote 0 down vote accepted
+150

It's possible that by upgrading, the old owning user was not well converted to the new Windows version, therefore D: is owned by a phantom user.

The first step is to take ownership of D.
Start a Command Prompt box (cmd) using Run as Administrator, and enter:

takeown /r D:

(Use takeown /? for all options)

Then to give yourself full rights on the file:

cacls D: /t /e /G username:F

cacls can be used with wildcards and directory traversal. See:
Security from the command line with CACLS.

For a more evolved Visual Basic script see:
Xcacls.vbs to modify NTFS permissions.

share|improve this answer

I would guess that you don't have full control over the D: drive for your username. I don't know for sure, but 2008 may be more heavily locked down than Win7 or Vista.

It also could specifically be that the browser is running as more limited than administrator. Try to "run as" the browser as the Administrator account if you have access, or your account if you don't.

share|improve this answer
    
I think that's not the case. My user is a local administrator on my laptop. I think it's sort of the same issue as when you can't copy files from a network drive and directly to some folders, but have to land it somewhere else locally and then copy it. Still haven't got a clue as how to disable it. Also, I'm running Hyper-V and when I attach a vhd from my D: drive i get an access denied when i start up the virtual pc. If that's a lead. –  user19353 Jan 11 '10 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.