Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Windows 7 Enterprise. When I click on a favorite folder (left hand pane) in a My Computer window, it opens into a new window even though I have the folder options set to "open each folder in the same window". Is there anyway to change this?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

Love it when people suggest conflicting things on forums... These things are all claimed to solve your problem!

Suggestion 1:

Have a look at this registry key and check that it says: None

HKEY_CLASSES_ROOT\Directory\shell

Suggestion 2:

My Fix:

open "regedit" (Start/Run...)

go to

"HKEY_CLASSES_ROOT\Directory\shell" and change the (Default) field to "open" (without the quotes)

Ready!

Suggestion 3:

1- open the registry editor (Winkey+R and type in "regedit")

2- Navigate to HKEY_USERS\S-1-5-21-3831040691-3390046849-3855596486-1000\Software\Microsoft\Windows\CurrentVersion\

3- Find the "Explorer" key and delete it, it will be then recreated.

4- Reboot

** Please keep you should always back up your registry before you make registry edits. Also, this is something I found through a Google search and although people have reported it works for them I can't be sure as I haven't tried it.**

Last resort:

http://www.kellys-korner-xp.com/regs_edits/settingssamewindow.reg

or

http://www.kellys-korner-xp.com/regs_edits/opendefault.reg

share|improve this answer
    
yep, says "none" –  Mark Jan 18 '10 at 17:37
    
Following suggestion #2 fixed the issue for me. Thanks! –  Mark Jan 21 '10 at 20:19
add comment

The cause of this issue was that the explorer always gets launched with My Computer in the breadcrumb bar. This seems to break all kinds of things including opening each folder in it's own window by single clicking and breaking the breadcrumb bar itself, but the solution is simple (no registry edits required):

  1. Right click on 'windows explorer' icon on the taskbar
  2. Then right click 'Windows Explorer' item in the jump list again.
  3. Then choose properties
  4. Then on the shortcut tab change target from:

%SystemRoot%\explorer.exe /root,::{20D04FE0-3AEA-1069-A2D8-08002B30309D}

to:

%SystemRoot%\explorer.exe c:

That makes explorer start in C: which avoids the whole problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.