Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed a game, which uses the StarForce protection under Windows 7 (64-bit).

After game installation, StarForce displayed a message, asking for a reboot. Since the reboot, Windows 7 doesn't start properly. It shows a text mode dialog (Recovery or Start Windows normally). Selecting any option leads to graphic mode rescue dialog (that with many different options). Sadly, I have to system images.

Is there a way to recover Windows 7 by deleting some files?
(By using GParted or something...)

share|improve this question

4 Answers 4

up vote 2 down vote accepted

From StarForce – the ultimate evil :

No big deal, boot up in safe mode and delete the problematic drivers, right? No such luck, StarForce had even managed to install these broken drivers in safe mode.

Next stop, the Vista installation disk, which has a repair feature. The repair went as expected, showed success, but when I tried to reboot, the problem was still there.

Luckily I had a Knoppix Live-CD lying around from some old experiments, and this was able to boot the machine into linux. A couple of driver downloads later I was able to access the files on the main hard drive, and delete the offending StarForce drivers by hand, which fixed the problem.

List of drivers from How can I get rid of Starforce? :

Unofficial way to remove Starforce

  1. Remove these files:

  2. Remove these registry keys:

share|improve this answer
Removed the files. One or two files had higher numbers at the end. Now, I'm going to restart and see... –  java.is.for.desktop Jan 9 '10 at 18:13

God bless Star-Force - punishing people who buy games whilst pirates who download the game apply a patch and never even know that Star-Force is the DRM.

At the start of your system, even before the screen comes up that asks to go in to recovery, try pressing F8 and choose Safe Mode. Once in, follow the guide from Star-Force's website and you can try an update, but if it still fails to start, do a full removal uninstall of the game and driver.

share|improve this answer
Sadly, safe mode also brings me to that graphic recovery screen :( –  java.is.for.desktop Jan 9 '10 at 11:00
What about booting to Last Known Good Configuration? –  harrymc Jan 9 '10 at 11:47

Last known good also didn't work. Using Vista 64 bit. Fortunately system recovery worked, but it took a few hours. However on finally booting had to re-install some software. Some installed software wasn't working either.

share|improve this answer

http://www.sevenforums.com/tutorials/139576-startup-repair-infinite-loop-recovery.html This worked for me after I installed my old brothers in arms: earned in blood which uses starforce. Im running windows 7 ultimate x64.

share|improve this answer
Could you perhaps edit your post to explain what you did? –  Simon Sheehan Nov 6 '11 at 11:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.