Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Currently i have GRUB2 with Ubuntu 9.10 installed, including 2 other O/S. I have an entry for an o/s in my grub.cfg:

menuentry "My OS" {
    insmod ntfs
    rootnoverify (hd0,6)
        makeactive
        chainloader +1
}

However, when i run this, it says that the makeactive command does not exist. Ive already tried some things like 'active' and 'make active', but all give me the same error.

What is the makeactive command in Grub2?

share|improve this question
add comment

1 Answer 1

The makeactive command has been replaced in GRUB2. You are now supposed to use parttool.

To set a partition's active flag with parttool:

parttool (hd0,6) boot+

and to remove it:

parttool (hd0,6) boot-
share|improve this answer
    
i tried this, and it said 'rootnoverify' does not exist. so i removed that line, but now it gives me 'error: not primary partition'. what to do? –  Deniz Zoeteman Jan 9 '10 at 10:18
    
Linux only allows 4 primary partitions. You appear to have the data installed to a non-primary partition. This is a different question which doesn't relate to makeactive though, and it seems you've already made another question for that purpose. –  John T Jan 9 '10 at 10:49
    
Yes, although it isnt answered, and only watched +/- 5 times in 1 hour. –  Deniz Zoeteman Jan 9 '10 at 12:40
1  
to clarify, "4 primary partitions" isn't a Linux limitation, it's a limitation of the MBR partition table used to partition the drive. –  quack quixote Feb 10 '10 at 14:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.