Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have just installed Cygwin and Openssh on my win7 box. After setting up the openssh, I can log in with my account (of course admin). But, I found my account under Ssh shell is filtered as a standard user. I know this is because UAC, but I wanna my account under ssh shell is real admin.

update: here is a way to do this, quoted from kb951016:

  1. Click Start, click Run, type regedit, and then press ENTER.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  3. If the LocalAccountTokenFilterPolicy registry entry does not exist, follow these steps:
    • On the Edit menu, point to New, and then click DWORD Value.
    • Type LocalAccountTokenFilterPolicy, and then press ENTER.
  4. Right-click LocalAccountTokenFilterPolicy, and then click Modify. In the Value data box, type 1, and then click OK. Exit Registry Editor.

Note: This change has a impact on system security, use it at your own risk

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

disable UAC as long as you want to ssh in it:

Control Panel -> search User Account Control.

share|improve this answer
    
Why are you posting in base64? –  John T Jan 9 '10 at 10:52
    
O wait? am i? A friend of mine is coding a browser, but it seems it doesnt work that well.. will edit the answer. –  Deniz Zoeteman Jan 9 '10 at 10:55
    
fixed with online decoder –  Deniz Zoeteman Jan 9 '10 at 10:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.