Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed VirtualBox 3.1.2 (latest) on my Windows 7 (x64). In the VirtualBox I've installed Windows 7 (x64). I have 4 GB RAM installed. The guest has been assigned a 1536 MB RAM. Sometimes the CPU usage on the host goes 100%.

It happens everytime, in a few minutes, after starting the guest. Then it stops responding. Then I have to "power off the machine" from the menu without doing a proper shutdown. It happens with Windows XP as guest too (even when the RAM amount assigned to it was the same). What is the problem?

share|improve this question

closed as too localized by Sathya May 20 '11 at 5:02

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
After "powering off" the virtual machine, the host CPU usage is back to normal. –  Sarveshwar Jan 9 '10 at 12:54
    
Try booting the guest in safe mode. If the guest CPU spikes, you know you have a deep problem because safe mode only loads essential parts of the OS. To eliminate VirtualBox, you could power on the guest and prevent the OS from loading by holding the boot process at the safe mode F8 screen and not selecting a choice. –  Scott McClenning Jan 10 '10 at 2:48
    
Today while running Skype, I got an error that read"C:\$Mft is unreadable or currupt". Check the disk using chkdsk. Are these problems related anyway? –  Sarveshwar Jan 10 '10 at 7:24
    
Checked with chkdsk. Nothing serious there. "Windows checked the disk and there was no problem found" was the ckhdsk's answer. –  Sarveshwar Jan 10 '10 at 7:31
    
I had the same problem of CPU at 100% with a new installation of XP. This question and the best answer solved it. So I'd like to vote for this question to be re-opened. –  FiveO Oct 10 '13 at 8:39
add comment

4 Answers 4

The following has completely solved the problem for me :


Your CPU will, by default, prompt Windows to load the ACPI-enabled SMP kernel. So when you switch to having Windows virtualized, this kernel remains and uses some ACPI registers that have severe virtualzation penalties (it talks to the BIOS).

The solution is to force Windows to stop doing that. You can do this by going to Device Manager (right click on My Computer -> Hardware -> Device Manager), expanding ‘Comptuer’, right-clicking ‘ACPI Multiprocessor PC’, select ‘Update Driver…’, choose manual installation, from a list, and select ‘Standard PC’.

Then reboot your guest VM.

share|improve this answer
    
Thanks jrm for the reply... this question was asked a long time ago... I am currently not using any virtual machine. VirtualBox is an awesome tool, though. I will apply your solution whenever I have the need to install VBox. –  Sarveshwar Jul 10 '10 at 7:27
add comment

the CPU is not virtualized, obviously the guest OS is performing some CPU-intensive task(s) after the start which subsequently affects the host.

you should tweak the guest OS (disable unnecessary services and programs).

share|improve this answer
    
okay... I have already disabled every startup program - gtalk, yahoo and a couple of others. I can't just figure it out what program is so CPU intensive. –  Sarveshwar Jan 9 '10 at 22:07
add comment
up vote 1 down vote accepted

Since I didn't get any help here nor on the other sites, I checked for other VirtualBox alternatives and came across VMWare. Its performance is really great! Plus I get to see the Windows aero style activated on VMWare! I immediately switched. Deleted the old VMs as they had to be converted from vdi to vmx. I didn't want to take all the trouble.

Currently I have installed VMWare Player which is FREE! It has Windows 7 as guest with aero activated and it works fine. Hope VirtualBox gets improved so that I could sswitch back. But not before they add aero support!

share|improve this answer
1  
After three months I am back to VirtualBox now. No issues. –  Sarveshwar Apr 16 '10 at 7:53
    
Damn... I will NEVER install this VBox again. Installed XP SP3 and what I am facing is 50-60% CPU usage on HOST while the GUEST is using 0-1% (idle state) of CPU. I have checked everything. The VBox is using that 50-60%. I am NEVER installing that again. –  Sarveshwar Apr 17 '10 at 0:33
add comment

Found the solution: Disable the Firewall/ICS service of your Windows XP (guest) and reboot.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.