Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This comes out to about 12 to 16 megabit/seond. I've read in forums that people are getting much higher speeds (ie: "40-60 Mb/s" http://forums.cnet.com/5208-7589_102-0.html?threadID=265967). I'm getting my benchmark by having a unmanged 5 port switch connected to a WRT54GS router connect. I'm sending a file from a computer connect to the WRT54GS to another computer that's connect to the unmanaged 5 port switch. Is the linkage of the switch causing this massive overhead? i doubt it. What could explain the slow down? electrical interference?

share|improve this question
1  
much traffic on lan? what is the switch? Are the file source and destination internal hard drives? –  RJFalconer Jan 9 '10 at 17:45
    
You can see how much throughput you can get my taking the speed of the network * the latency (e.g. 1 Gbps * 100 ms = 100 Mb ~ 12 MB). That said, I've noticed a speed difference when transferring from disk to disk and RAM disk to RAM disk, so the choke point may not be the network. If you are talking about Windows here is an interesting video about how Windows uses bandwidth and the changes in Windows 7 (Windows 7: Optimizing Applications for Remote File Services over the WAN channel9.msdn.com/pdc2008/ES23) –  Scott McClenning Jan 9 '10 at 19:13
    
@Scott I really have to question your equation for throughput, unless you're using a strange definition of the term. –  phoebus Jan 9 '10 at 20:30

2 Answers 2

up vote 1 down vote accepted

At a full 100Mbit/sec link the max would be roughly 12Mbytes per second. Since you're getting less than that by a factor of 8 I would suggest there is a problem somewhere.

Right now you say your source computer is connected to the router and your target is connected to the switch. I suggest you connect them both to the switch and try it again to eliminate the connection from the switch to the router as a possible problem.

share|improve this answer

A little bit slow for windows file transfer.

I'd expect 3.3 megabytes per second and you're getting half that.

100/10 ~= 10 Megabytes per second raw ethernet at roughly 8 bits per byte plus overheads.

then windows tops out at about 30% of any given network. consider it MS tax.

so 30% of 10 is 3.3 megabytes per second.

So yes, below normal, but not markedly.

cableas are okay and both computers have clean 100meg connections ?

If you're getting link errors that will slow things down.

Check both pc's using the manufacturers diagnostics for the cards in question. (for most vendors it installs by default from their driver disks.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.