Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Windows 7, and IE8.
Often, when I have IE8 open, and I resume the computer from sleep, I get the question about working offline - even if at that moment the wireless connection is available.
This is particularly sad, because all browsing is stopped until I dismiss that dialog, that may be hidden below other windows. This is more frequent if I have GMail open in a tab, but this behavior comes from other sites as well. I suppose, GMail triggers it more often just because of its background updates.

As I am not using offline browsing at all, is it possible to disable the functionality altogether, so that I no longer get the question? A bit like in Firefox, where I simply get the error message with page unavailable.
I have googled a bit, but no luck so far. Even a direct modification of the registry would be fine, for me.

share|improve this question
4  
maybe a good suggestion: avoid using Internet Explorer 8 – Raptor Jul 31 '10 at 11:18
up vote 2 down vote accepted

Windows 7 Service Pack 1 contains a fix for this:

KB982370: You receive a "Work Offline" dialog box in Internet Explorer 8 after the computer resumes from sleep or from hibernation

Consider the following scenario:
- You use Windows Internet Explorer 8 to browse web pages.
- You put the computer to sleep (S3) or into hibernation (S4). - You resume the computer after a while.

In this scenario, you receive a Work Offline dialog box in Internet Explorer 8. However, the computer is connected to the Internet.

share|improve this answer
    
I think you are right, because lately I have not seen that annoying message any longer. – Roberto Liffredo Mar 31 '11 at 5:53
    
i decided to troll for some free rep. i read the release notes of SP1, then searched SU for matching problems. Write up an answer, link to the KB article, Bam! :) – Ian Boyd Apr 11 '11 at 21:15

all browsing is stopped until I dismiss that dialog

Use ClickOff to 'dismiss that dialog' automatically, It's simple but efficient, this program can kill annoying pop-up messages and windows in a flash.

alt text

alt text

share|improve this answer
    
This is a workaround, and it is quite interesting. However, this is not really the solution - that would be how to disable that request at all. – Roberto Liffredo Jan 10 '10 at 0:19
    
wireless network devices and sleep mode has always been dodgy affair and that hasn't much improved with Vista/7. the problem is certainly not with the browser, it's the device configuration. that said, some WLAN adapters are plain cr*p, i hope for you it's not a Ralink adapter :) – Molly7244 Jan 10 '10 at 0:52

I found this fix on a forum, didn't test it.

Look in the registry (START >> RUN >> REGEDIT)

Using regedit, find the folder:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\WebCheck

And check that these two String keys are set to auto: "LoadSens"="auto" "LoadLCE"="auto" Create them if necessary!

http://www.anetforums.com/posts.aspx?ThreadIndex=4068

share|improve this answer

Me- Vista with IE 8. I always have a couple of links on my desktop to go to websites other than my homepage so I click one of those, then I receive an IE message that asks me if I want to Connect or Work offline. I click connect.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .