Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Emacs 23.1 with Cygwin but when I try to exit by pressing C-x C-c it says C-x C-g is undefined and I am not able to exit.

share|improve this question

This problem can be fixed by inserting the following line in file Cygwin.bat before the line with bash --login -i:

set CYGWIN=tty notitle glob

File Cygwin.bat is in the root of the Cygwin installation and is also the file that there is a shortcut to in menu Start/Programs/Cygwin. The shortcut may be named Cygwin Bash Shell.

I have tested it and my version of the Cygwin.bat file now contains:

@echo off

chdir e:\cygwin171\bin

set CYGWIN=tty notitle glob

bash --login -i
share|improve this answer
Thank you, this fixed it for me! Should definitely be the accepted answer. – Skilldrick Jul 14 '10 at 14:41
This worked for me as well. Thanks! – 31eee384 Feb 11 '11 at 21:24
@31eee384: you are welcome! – Peter Mortensen Feb 11 '11 at 21:36

Sounds like a Cygwin issue, interpreting Ctrl-c as Interrupt and Emacs somehow translating that to its interrupt character, Ctrl-g.

As a workaround, you can always exit Emacs by doing Meta-xsave-buffers-kill-terminal .

share|improve this answer

I had the same problem and just solved it by adding a Windows environment variable called CYGWIN with the value "tty".

share|improve this answer

You must log in to answer this question.