Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I bough a new hard drive and I'm attempting to copy stuff off the old hard drive to the new one. I tried it using Windows Vista and Windows 7 but no go. Then I tried installing some 3rd party updated drivers that were supposed to fix the problem now my Windows Vista disk won't boot. Has anyone had this problem before and how did you fix it?

share|improve this question
    
Not sure if you know what a semaphore is, but if not, it's basically something that lays claim to a device (or any other resource) on your computer. While a program is using that device, it keeps a semaphore for it, and when it's done, it releases its claim over it. Any semaphore problems that consistently creep up are going to have severe consequences. While it may or may not be the OS' fault (perhaps a driver issue not allowing one process to complete it's task and then relinquish the device once it's done) This is an error at the very heart of the OS, not some superficial error. –  Michael Jul 25 '11 at 10:55
    
Since the error is not very specific, I doubt anyone can help without knowing other info such as the HDD type, driver name/version, etc., and even then it's a shot in the dark. –  Michael Jul 25 '11 at 10:58
add comment

2 Answers

You must rollback your system to before the drivers update were done.

Boot into Safe mode by pressing repeatedly F8 when Windows is loading, then restore to the latest restore point dating from before the change.

Once your system is back to a working state, you might post separately your data recovery problems. I don't believe that it's a driver problem.

share|improve this answer
    
The entire installation is hosed. I couldn't even boot up into safemode. I was just putting that in there to rule out the 3rd party drivers as a solution to my problem since I'm not going to do that again. I may be able to get it bootable again by using the install disk but since I have a windows 7 drive I did in parallel trying to upgrade I figured no reason to go back to Vista if it has the same problem. –  Ryan Jan 10 '10 at 20:12
1  
I understand that the Vista disk is dead and not worth recovering (recovery is another subject). But whatever you do, don't reinstall these drivers! –  harrymc Jan 10 '10 at 20:40
add comment
up vote 0 down vote accepted

The motherboard had issues with its SATA controller (drivers or hardware I don't know.) I moved my hard drive over to the RAID SATA controller and it worked for about another year before that died as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.