Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my new USB disk. When I connect it to my laptop with Windows XP SP2 it takes about 4-5min until Windows recognizes it and shows it as a new disk. I can also see (disk's LED is blinking) that something is scanning the disk when I connect it; when this is done Windows immediately recognize it.

Also when I'm copying data to this disk the speed is about 3.5MB/sec. It's connected using USB2.0.

I tried to check for spyware (using Spybot), also tried running Windows in safe mode. But still have the same problems.

Do you have any idea what could help to solve this problem?

On Windows Vista (another laptop) everything is ok, disk loads in about 15sec and speed is about 20-30MB/sec.

Edit: I tried to update to SP3 - no change

Edit2: When this "strange" scanning occurs I can see that DPCs process is taking about 50% of CPU. When the scan ends (after 5min) this process take 0% again.

Edit3: About the scan time, currently it's taking about 5min, but this time is growing as I'm adding more data to the disk, currently its about 40GB and I don't want to see how long it will take with 1000GB.

Thanks a lot for every advice!

share|improve this question

5 Answers 5

Do you have a lot of usb devices such as cameras, video recorders/camcorders, scanners, printers or other? and more importantly, do you use the disks that come with them to install the drivers?

I have seen this typically on old, bog-downed machines when you have a lot of devices. Typically the disks that come with them install monitoring tools that listen for when their device connects.

If you have had a lot of devices but never uninstall the software, this sort of behaviour can occur.

I would recommend you uninstall any software or drivers that you are not using and try again.

If this is not the case and you have no other devices, do you have any other USB sockets you can test it on?

Lastly, you may want to take a look at Nirsoft USBDeviceW which should allow you to remove cached/old USB devices you are no longer using but your machine still has registered.

share|improve this answer
    
Thanks for a very fast response. But unfortunately this is not the case. I'm using just one - camera but I removed it. I also tried all the sockets but still the same strange behavior. "Something" is scanning the disk ... (I tried to kill every running process using procexplorer but still the same problem). Anyway thanks for your help! –  user24311 Jan 10 '10 at 20:37
    
USBDeview helped a lot. It would take 10 seconds for my KVM switch (Belkin Flip) to be recognized under XP, but using USBDeview to remove old devices brought it down to a second and a half (although still not the fraction of a second it takes Linux to see it :P). –  Ignacio Vazquez-Abrams Jan 6 '13 at 13:55

There are known issues with USB drives in Windows XP Service Pack 2 (which have been addressed with Service Pack 3, time to upgrade! :).

Here's an excellent Troubleshooting Guide for USB drives

This website is also home of the excellent USB Drive Letter Manager for Windows.

share|improve this answer
    
Thanks I will check the pages. Ohh and I need to update the question, I also tried to update to SP3 but no change :( Thanks for your help! –  user24311 Jan 10 '10 at 20:39

I tried all the above in XP Professional SP3 and solved the slow logon during boot up of my 750 GD WD USB drive as follows:

  1. In Control Panel → Users I removed the ASP.NET Machine account as a user (I don't know how it got there - probably an update and I don't have a server)
  2. Stopped fast index searching on the drive in question.
  3. Removed Windows Restore access to the drive; it's only used by Acronis for backup.

The drive is now instantly recognized and Windows boot up is much quicker. I'm not sure if one of these or a combination was the solution but it fixed it.

share|improve this answer

try with different usb. if the problem is still there try to scan your pc in safe mode

share|improve this answer

The problem could be the power...if you don't attach an external power supply to the disk, do so and see if it speeds things up.

Also, check the disk for errors, this could be also caused by a faulty harddrive.

As a lest resort, you could boot into a Linux-Live-System and check how the drives behaves with that.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.