Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have English Windows 7 Professional with Hungarian keyboard language installed. The English keyboard layout works as expected, but for the Hungarian layout some kind of "accent combining" is activated.

The effect of this ^+o becomes ô, ^+a becomes â, etc.

This is not helpful at all, since the accented characters of Hungarian are already mapped to keys, but it's really annoying because I have to type a non-combining character to actually get ^.

Is there any way to turn this "feature" off?

share|improve this question
add comment

4 Answers 4

How to create a custom keyboard layout on Windows 7

  1. Get Microsoft Keyboard Layout Creator as noted by @bubu.

  2. Start Microsoft Keyboard Layout Creator
    enter image description here

  3. We're going to load an existing keyboard
    enter image description here

  4. And Hungarian it is!
    enter image description here

  5. The accent characters seem to only be available on the Hungarian layout when AltGr is pressed. So let's view that layout.
    enter image description here

  6. Right-click one of the accent keys you want to change. And uncheck the option Set as dead key.
    enter image description here

  7. Confirm your choice by clicking OK.
    enter image description here

  8. The key has now become a regular key and will behave like any of the normal letters. Repeat this process for all other keys you want to change.

  9. Export your new keyboard layout.
    enter image description here

  10. When asked to review your layout properties, confirm and adjust them to your liking. When you're done, press OK.
    enter image description here

  11. You will now get a folder with an installer package for your keyboard layout.
    Install it and you will be able to select your new keyboard layout from the system dialog.
    enter image description here

  12. This is the dialog where you would usually select your keyboard layout. You can even see my customized layout German - Programmer which is a customized German layout without dead keys (the same thing you want to achieve).
    enter image description here

A word of advice though! Using custom keyboard layout can have some undesirable effects.
For example, when using RDP to connect to another Windows machine, that machine will not know your keyboard layout and switch to English.
Before I used my custom layout, the other machines would happily adapt to German layout.

If you have issues with your keyboard layout being switched around during RDP sessions after using this procedure, please see: How can I stop the remote computer from changing my keyboard layout?

It's still worth it.

share|improve this answer
add comment

I learn The Microsoft Keyboard Layout Creator from another post (here: Pound sign on Windows on MBP with US keyboard )

Maybe it would help to use it?

share|improve this answer
add comment

Those keys are called "dead keys" -- they don't output anything until you press a second key (which should combine to create a new character).

You can just press space after inputting one of those. (this solution works in X11, Windows and OS X)

share|improve this answer
1  
That's the problem! I can't type normally, if I have to press an extra key every now and then. The point is to disable the whole thing competely. –  shinjin Aug 5 '11 at 7:37
add comment

The answer provided Oliver Salzburg didnt fix the character accent combining for me. Have a look at this http://www.youtube.com/watch?v=G015Lna65hs.

This fixed my problem. What kept going wrong was that I needed to first set the default input language to US and then remove the wrong keyboard for good measure.

share|improve this answer
    
You should translate the instructions to your answer, in case the video is ever taken down. Additionally, it might appear as though you are attempting to drive traffic, which is not permitted. –  Raystafarian Aug 2 '13 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.