Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In linux (ubuntu 9.10, in my case), is there any command similar to gksu but without root privileges? I've followed the instructions on pida's site and installed pida 0.6. When I run it using ./pida-run.py from terminal it starts fine. But when I made a gnome menu item and indicated the above command (with the correct location) to run it, it wouldn't run. So I was thinking if I add gksu alternative, maybe it'll work.

Thanks

share|improve this question
    
What do you mean by gksu "without root privileges"? Isn't conferring root privileges all gksu does? –  Blorgbeard Jan 11 '10 at 6:04
add comment

2 Answers

up vote 2 down vote accepted

I don't think you need gksu here..

Try changing the menu item's launcher type to "Application in Terminal" - maybe you'll see error messages come up.

share|improve this answer
    
thanks, it worked –  Baha Jan 11 '10 at 6:21
add comment

Although I agree with Blorgbeard that the following won't solve your actual problem, but in the interest of answering the question asked, you can pre-pend the command field in the launcher with:

gksu -u username

and the command should be run as the user username

Remember, the su means "switch user" despite the fact we mostly use it to become super user.

In general, when I have seen things work from a terminal but not from a launcher, some aspect of the environment is not being set the same way as in a terminal session.

share|improve this answer
    
thanks for the answer –  Baha Jan 11 '10 at 9:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.