Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having trouble connecting two computers running Windows via Remote Desktop Connection. The intended RDC host is running Windows Vista Business, and the client is running Windows 7 Home Premium.

The two computers are not on the same LAN. The host is behind a Linksys WRT54G2 router. I've forwarded port 3389 (TCP and UDP) on the host router to the local address of the host computer. I have also enabled remote access on the host computer by checking off 'Allow connections from computers running any version of Remote Desktop' in Computer->System Properties->Remote. The host computer is running McAfee VirusScan Enterprise 8.7i, and I've created an exception for 'Remote Administration Tools' in the console's 'Unwanted Programs Policy'.

I can connect to the host computer via Real VNC Viewer -- this simply required forwarding port 5900. On the host's router I enabled logging for incoming traffic, and in that log I see incoming traffic from my client computer's IP address on port 3389. However, the port appears closed when I test it at http://canyouseeme.org/.

Thanks in advance for any help.

share|improve this question

2 Answers 2

Are you able to connect to the host from another machine that is on its local network? That would let you know if the computer itself is the problem or some firewall between the computer and the public Internet.

If you are not able to connect from the local network, then my best guess is that you have another firewall enabled somewhere. It's not infrequently that I run across machines with both the Windows Firewall and a third-party firewall enabled.

Addendum: If the computer is not even listening on port 3389, really I can only off the top of my head think of three possibilities:

  1. Somehow the RDP port has been changed. The KB "How to change Terminal Server's listening port" describes where to find this (HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp)

  2. The Terminal Services service (TermService) is not started. Perhaps it is not set to automatic startup?

  3. Operating system damage from malware or other misconfiguration. I suspect this option would be obvious if it were the case, though.

share|improve this answer
    
It may also be the ISP that is blocking port 3389, though you'd have thought that if VNC is allowed through then RDP would be too. –  kaerast Jan 11 '10 at 10:35
    
I just ran 'netstat -a' via command prompt on the host computer and found that it isn't listening on port 3389. I've also uninstalled McAfee VirusScan and disabled Windows Firewall. Considering that RDC still isn't able to connect, is it safe to assume that the problem is probably not due to issues with the router or firewalls? –  user24357 Jan 12 '10 at 2:44
    
That is good information you've given. I've added to my answer, hopefully it helps. –  Stephen Jennings Jan 12 '10 at 3:03
    
I've checked the relevant value in the registry: the port number value is the normal 3389. The Terminal Services service is running as well, but port 3389 is still missing from the collection of ports returned by 3389. Thanks for your help troubleshooting. –  user24357 Jan 13 '10 at 5:20

I would guess that it's either the Windows 7 firewall or McAfee that blocks the connection.

Try turning them completely off. Once you find out which one is the problem, parametrize it as required.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.