Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I found out that when I press the Insert key on the client I will block the OS X VNC server by putting it in a "help mode" where you get the question mark mouse cursor.

The mouse works but I cannot use the keyboard anymore.

Details:

  • Reconnecting using VNC does not help
  • Normal keyboard is working fine on the mac

The only solution in addition to relogin was to stop the VNC server on mac using:

  killall OSXvnc-server

After few seconds it will restart by itself and it will work.

I don't like current workaround and looking for something better.

Tested with these versions of the VNC client and all put the VNC server in the question mark mode, requiring service restart:

  • Ultr@VNC 1.0.8.2
  • RealVNC 4.1.3

I know that the problem is caused by the different/bad implementation of the VNC protocol in the server but do you need an workaround?

share|improve this question
    
Apple forum is so nice - people complained about this issue and apple marked the thread as Solved! and archived it (readonly) discussions.apple.com/thread.jspa?threadID=2222053&tstart=0 –  sorin Jan 13 '10 at 14:59

2 Answers 2

This is fixed for me using Vine Server 4.01 on mac side and UltraVNC viewer 1.1.9.1 on windows side.

Default settings on server side produce the bug (very annoying).

To fix, open Vine Server preferences, Advanced tab, change Keyboard Events to User Session Events.

Happily using Ctrl+Ins/Shift+Ins for copy/paste in xcode now.

Note: this will likely break any keyboard remapper you have that relies on hardware events.

share|improve this answer

From Mac OS X - VNC curson becomes QUESTION mark - unable to type (with experts-exchange.com you might need to google for it, then scroll to the end to see the answers):

Answer 1:
This problem occurs when you use UltraVNC version 1.0.5.2 (possibly anything 1.0.5.+?) and hit the INSERT key on a Windows machine. At that point your only option appears to be to logout and log back in. This problem does not occur with UltraVNC 1.0.2 or the latest version of TightVNC or RealVNC. Also, FYI, Mac OSX has a built in VNC cilent, you do not need to install Vine VNC unless you want per-user VNC sessions. Only TightVNC or UltraVNC 1.0.2 appear to be able to connect to the default OSX VNC server, the others fail.

Answer 2:
I don't to this in my environment, but in the Mac world the key should be Command-C to copy and Command-V to paste. Not sure if VNC client changes that or not...apparently it might given the answer above...but you might give it a shot.

Answer 3:
This may sound silly... but I don't use CTRL-C to copy... it does not work for me using TightVNC... I use ALT-C... that copies for me.

share|improve this answer
    
Thanks for clarifying! I voted for it but I cannot accept it as an answer because it does not provide a solution. –  sorin Jan 13 '10 at 14:31
    
The solution is apparently using the latest version of TightVNC or RealVNC. –  harrymc Jan 13 '10 at 15:09
    
I tested latest TightVNC and RealVNC and they still have the "Ins" key bug that blocks the Mac. –  sorin Jan 27 '10 at 21:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.