Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the Linksys WUSB300N USB Wi-Fi adapter under Windows Vista Home Premium x64. The problem is it doesn't wakeup when computer goes out of standby. It's really annoying.

I have 1.0.3.2 version of drivers dated 2007-09-11, and I think they are the newest ones.

In the network adapters/Wireless-N USB Network Adapter/Properties/Power Management I have "Allow the computer to turn off this device to save power" unchecked and "Allow this device to wake the computer" is inactive (disabled).

I have a couple of other USB devices and there is no problem with them after the computer wakes up.

share|improve this question
    
Has anyone accomplished this wirelessly ? –  Antoine Benkemoun Jul 6 '09 at 11:24
    
@flashkube Yep, could be a company laptop. Edit to read Vista Business Premium and question suddenly becomes legit. –  gyaresu Jul 11 '09 at 3:47

10 Answers 10

First thing to check is that the computer is not set to turn it off to save power:

  • Open device manager
  • Expand Network Adapters, right-click your Linksys Wireless device, and then click Properties.
  • Click the Power Management tab.
  • The Allow the computer to turn off this device to save power check box is displayed, make sure it is unchecked.
share|improve this answer
1  
This has been the fix for me with multiple XP systems. –  Kara Marfia May 25 '09 at 0:44
    
Thought the same and unchecked it some time ago. No change. –  Piotr Dobrogost May 26 '09 at 16:12

It sounds like Vista SP2 might be of use to you


"Microsoft says that the Service Pack will also bring... improved Wi-Fi performance when resuming from Sleep mode

share|improve this answer
1  
I do like the 'improved performance' meaning it works at all. Perhaps I should try that, improved execution lifetime = it doesn't immediately crash –  Martin Beckett May 27 '09 at 13:58
    
I installed SP2 and this didn't help. –  Piotr Dobrogost Jun 5 '09 at 10:05

Also check the Advanced Power Options. Vista can be set to turn off the USB ports to save power.

Since your WiFi device is USB-based, that may be the problem.

share|improve this answer

On Windows Vista, I had some troubles with the Wi-Fi startup until I add the following script at startup.

net stop Wlansvc
net start Wlansvc
share|improve this answer

The drivers are the newest ones, and it is an issue that will probably never be fixed by Linksys. The only solution I have found can be found in A USB device may no longer work correctly after Windows Vista resumes from sleep or from hibernation.

Follow the instructions starting from the Post-installation instructions section.

share|improve this answer
    
Nice link, thanks. Did what was prescribed but it didn't help. –  Piotr Dobrogost Jul 9 '09 at 10:13

I have seen this issue with Wi-Fi cards and many USB devices. The latest drivers and playing with your power saving settings are the way to go. Stopping and restarting the device has given me some success, but it is hit and miss.

share|improve this answer

Have you looked in your BIOS settings to see if there are any options for USB settings? Also, have you tried something else like a USB hard drive to see if that spins back up after waking the computer from sleep? That may help see if the problem is with the adapter or the port.

Lastly, I'd move the adapter to another machine to see if it does the same thing (ideally one using XP or a different OS than you're currently using).

share|improve this answer
    
I have a couple of other USB devices and there is no problem with them after the computer wakes up. –  Piotr Dobrogost Jul 15 '09 at 13:38

I've had a similar problem with intel network cards. My work around was to run a batch file when you wake the PC up.

If you want to do it this way, the utility you need is DevCon. You then use this in a .bat file using the restart argument and then name of the device which you can find using the findall argument.

share|improve this answer

In the Windows Device Manager, I would check to see if the USB Wi-Fi adapter has any power-related settings in its hardware configuration. I know that I've remedied various wakeup issues with Wi-Fi cards and Windows Vista by adjusting their settings within the Device Manager (but never a USB adapter, so this is a bit of a crapshoot).

share|improve this answer
    
In the network adapters/Wireless-N USB Network Adapter/Properties/Power Management I have "Allow the computer to turn off this device to save power" unchecked and "Allow this device to wake the computer" is inactive (disabled). –  Piotr Dobrogost Jul 15 '09 at 13:35
    
And those settings were like that by default? –  Matthew Ruston Jul 15 '09 at 13:40
    
No, I changed them. I don't remember default values, however. –  Piotr Dobrogost Sep 28 '09 at 7:30

http://catalog.update.microsoft.com/v7/site/search.aspx?q=wusb300n

You obvously do not get any advantage of using non-HCL (never tested at microsoft) driver even with newer version number. Thus try one offered as part of windows HCL

share|improve this answer
    
The site shows version 1.0.0.4 from 2007-01-19 which is older than what I describe in my question. –  Piotr Dobrogost Feb 5 '12 at 22:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.