Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When using a tree view (e.g. the folders list in Explorer), there are little triangles next to each node which contains sub-nodes. Unfortunately, they fade out as soon as one leaves the tree view with the mouse. This is very annoying, because one can't see anymore which folders contain sub-nodes as soon as the mouse is somewhere else.

Is there a way to prevent Vista from fading out the little triangles?

share|improve this question
add comment

5 Answers 5

up vote 2 down vote accepted
+100

I miss the simplicity of the old windows explorer. That being said, the only way I know of to have some indication of which folders have sub-folders and which don't on Vista is as follows:

  • go to Control Panel
  • open Folder Options
  • go to the View tab
  • Under Advanced Settings and under Files and Folders
  • there is a checkbox: Display simple folder view in Navigation pane. Uncheck it.

Now in your folder tree view, the folder nodes that that don't have any subfolders will have a straight line flowing down their left side whereas those folders with subfolders have a blank space (where the triangle would be) on their left side with dots above and below the blank space.

share|improve this answer
add comment

I checked aero.msstyles (the file which contains all the visual resources) and it seems that treeview expander glyphs are resource ids #804-812.

I was hoping to find a transparent resource or zone which might have hold a non-hovered, transparent version of the expander, but it nothing like that seems present (the idea being that if such a resource existed, one could edit it with the appropriate expander icons).

I also checked Aero's UIFILE resource in shellstyle.dll, looking for something related to focus or mouse movement for treeview expanders. Again, no dice.

Therefore I think that it is probably not possible, at least not through editing the visual style files.

share|improve this answer
add comment

To stop the fade effect in Vista's tree explorer you need to change the "Fade or Slide Menus into View"

  1. Right click Computer > Properties
  2. Advanced System Settings
  3. Under Performance click Settings
  4. Un-check Fade or Slide Menus into View
  5. Apply
share|improve this answer
add comment

I couldn't find any way to do it by configuration, but clicking in that window (or clicking an item in the list) will stop the fade out.

share|improve this answer
1  
Unfortunately, they fade out again as soon as you click somewhere else again... –  Bob Jul 21 '09 at 17:32
add comment

I can confirm that there is no setting to change this. A comprehensive list of items that can be disabled is available here.

You can also have a look at the options under Performance.

  • System
  • Advanced System Settings
  • Advanced
  • Performance Settings
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.