Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

RDP client is connecting to the server just fine, but only drawing about half of the login screen and then stopping. This is happening on two of my Windows 7 Ultimate boxes, both of which are clean installs. I have three other Windows 7 Ultimate machines that are able to connect just fine, all of these are also clean installs. The only differences that I can find in the setups of the machines is that the ones that don't work properly have multi-core processors and have hardware virtualization support turned on (for XP Mode support in Win 7). I'm using a D-Link WBR-1310 router and having the same issue in both wired and wireless setups. Any help would be awesome. I may even dance.

share|improve this question
    
@Scott - Your question from SO was automatically migrated over here, so I asked to have them merged. Also, you may want to associate your accounts - go to your profile page and click the Accounts tab. It'll give you a rep boost here. – Jared Harley Jan 13 '10 at 3:35
    
please please please don't dance... – quack quixote Jan 13 '10 at 4:19
up vote 0 down vote accepted

Lots of variables here..

  • Does it happen if you use a crossover ethernet cable to directly connect the two machines, ruling out the existing switch/router and cabling?

  • Are there other differences is hardware configuration between the machines? Like video card, ethernet card, etc?

  • Have you tried updating the ethernet drivers? Windows 7 drivers are pretty up to date out of the box because the OS is so new, but I've seen really surprising problems from default windows ethernet drivers before.

  • Have you tried updating the video drivers? Those are always worth updating because they change so rapidly.

(You could also try using RDP from within a Windows XP VM on the same machine, just for kicks.)

I highly, highly doubt this is because the relevant machines are multi-core. I'd personally go on a driver-updating frenzy myself, based on previous experience.

share|improve this answer
1  
Previous experiences like this perhaps? :) blog.stackoverflow.com/2009/02/server-speed-tests – John T Jan 13 '10 at 4:37
    
I gave it a shot, and new network drivers didn't seem to solve the problem. I upgraded the wired NIC drivers on my desktop and laptop, as well as the wireless drivers on the laptop. Still having the same issue. – Scott Wolf Jan 19 '10 at 14:14
    
@scott did you try RDP'ing from the XP VM on the same machine? – Jeff Atwood Jan 19 '10 at 14:15
    
Seems to be working from the XP VM. Odd. – Scott Wolf Jan 20 '10 at 4:56

If this is the problem I've been experiencing (for years, at this point), here are some additional data points:

  • It only happens to me when I've got Aero enabled on the remote end. This might explain why you only see it in Windows 7 Ultimate - that's the only version of Windows (other than Enterprise) that allows remote desktop servers to pass Aero.
  • On my machines, the problem generally occurs if I scroll in a non-maximized RDP client window. It also happens if I minimize the client window (but not always).

There are two workarounds:

  1. Disable Aero. On the RDC client, this means unchecking "Desktop composition" on the Experience tab.
  2. If you want Aero enabled, then there's a workaround each time the problem happens. Press Ctrl-Alt-End to get the Windows Security screen on the remote machine. Then hit ESC to exit it. That should "wake up" the remote side.

I really hope MS takes this bug seriously some day and fixes it. Until then, we've got the workarounds listed above.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.