Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In Word there should be a functionality that when I right-click over any word the menu pops up and I can select the Synonyms. However instead of a list I only get a grayed-out No Suggestions and Thesaurus...

How can I restore this functionality? Ownership/Registry issue?

Another user on the system installed Office but we are both administrators.

share|improve this question
I know that it is a permissions issue based on the user level. Although you all provide an alternative solution, I am looking to restore this functionality specifically – ricbax Jan 11 '10 at 21:29

There are at least two possible solutions:

  1. Select the sentence in Word, and look at the language name near the lower left-hand corner of the Word document. Is the language and country name correct? If not,

    • Click on the language name.
    • Select the language and country name that Word should be using.
    • Click on the "Default..." button.
    • Click "Yes"
  2. Something is wrong with the installation.

    • Close Word and your other Office applications, then go to the Add/Remove Programs option in Control Panel. (Might have a different name, depending on which version of Windows you are using.)
    • Find Microsoft Office in the list of programs, and click on "Change"
    • Choose "Add/Remove Features" in the Office Setup dialog.
    • Click the pluses to expand "Office Shared Features"
    • Click on the down arrow next to "Proofing Tools", and select "Run All From My Computer"
    • Click "Continue" or "Next".
    • Wait for Office to reinstall the proofing tools.

If that doesn't work, then you can also try repairing the Office installation, instead of choosing "Add/Remove Features."

I hope this helps.

share|improve this answer

Something that works for me, if you press Alt and click on any word, it should bring up the research toolbar (with that word as the search term) and you can select thesaurus or any of the other options.

share|improve this answer

From this page it looks like the synonyms functionality is part of Microsoft Proofing Tools for Office 2003, which seems to be a paid for add in.

Has this been installed? If it has you might need to repair it or activate it.

Unfortunately I don't have Office 2003 installed any more to check on my system what the behaviour is when it's not installed.

share|improve this answer

Right click on any word and select Look up..., from the Reference Books drop down menu pick Thesaurus (Language)

share|improve this answer
up vote 1 down vote accepted

Well I finally got this one solved. I actually thought that it was an installation issue but even after installing MS Office 2007 the problem remained.

I originally copied another user's profile on the system, in doing so it inherited all the permissions of that user instead applying them to my username.

I therefore had to change permissions to my username for all programs on the machine as well as hunt through the registry to change any references from C:\Users\CopiedUsername to C:\Users\MyUsername

After doing so and restarting the PC, Voila, MS Word would produce a list of Synonyms for words I chose.

Had this been a Vista Ultimate or Business the task may have been much easier than in Vista Home Premium.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .