Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows 7 x64, the system Volume icon in the notification area/tray on the taskbar is missing. It was working recently, but it does not show currently. I have two audio devices - some on-board sound (default Microsoft drivers) and a Logitech USB headset. Both are working fine.

In Control Panel > All Control Panel Items > Notification Area Icons > System Icons, the "Behaviors" drop-down for the Volume icon is disabled. (This is also the case for the Power icon, but that seems reasonable for a desktop computer.)

How can I enable this icon again? It's handy and I miss it.

share|improve this question

4 Answers 4

up vote 15 down vote accepted

Take a look at Microsoft's KB on the issue:

When you start a computer that is running Windows Vista or Windows 7 for the first time, one or more of the following icons do not appear in the notification area in the lower-right corner of the screen.

  • The Network icon
  • The Volume icon
  • The Power icon

You may also notice that the check boxes for the related system icons are not selected on the Notification Area tab of the Taskbar and Start Menu Properties dialog box. However, the network, volume, and power features function correctly even though their associated icons do not appear in the notification area. You can access these features by using Control Panel.

If you gave your computer enough time to finish the startup service initializations before you restarted it, and one or more of the system icons still do not appear in the notification area after the restart, you can make them reappear by deleting two subkeys from the registry.

Microsoft provides a "Fix It For Me" file that will automatically make the changes needed to fix this problem. You can download the Fix It For Me solution from here, or follow these steps to fix it yourself:

  1. Click Start, type regedit in the Start Search box, and then press ENTER. If you are prompted for an administrator password or for confirmation, type the password, or click Allow.

  2. Locate and then click the following registry subkey: HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify

  3. In the Details pane, click the IconStreams registry entry.

  4. On the Edit menu, click Delete, and then click Yes.

  5. In the Details pane, click the PastIconsStream registry entry.

  6. On the Edit menu, click Delete, and then click Yes.

  7. Exit Registry Editor.

  8. Either restart the computer or the Explorer.exe process.*

*The easiest way to restart explorer is to click the start menu, press Ctrl+Shift and right-click on the empty area of the start menu and select "Exit Explorer".

Exit explorer screenshot

Then press Ctrl+Shift+Esc, click File -> New Tasks (Run) and type explorer and click OK. Close the Task Manager when you're done.

share|improve this answer
    
That worked perfectly. Thanks! –  Tim Danner Jan 12 '10 at 4:36
3  
Yeah thank God for this. It's incredibly difficult to search for a solution to this problem without being flooded by the trivial "enable the icon" solutions. –  Alain Feb 20 '11 at 14:11
    
It has solved the problem with the volume control icon but disabled the Action Center icon. Before applying the settings window was looking this way: i.stack.imgur.com/8BTEV.jpg (notice the volume icon switch set off and shaded) - now exactly the problem moved to the "Action Center". –  Ivan Apr 16 '13 at 16:30
    
I didn't have to run the fix. A simple stop/start explorer did it for me. Where the hell did you discover that explorer restart tip?? –  Gaia May 6 '13 at 16:08

Also, if (like me) anyone out there is a computer gumby and unable to get the volume icon situated back in the task bar by doing something complicated, do this simple trick in W7:

Search for "adjust volume," The control panel icon called 'adjust volume' will come up in the list of items, Click on 'adjust volume,' Then when it opens, right click on it, On the pull down menu, click "pin to the task bar."

Ta-daah. The volume speaker icon will then appear in your task bar.

share|improve this answer
    
This works great for people that are inexperienced with messing with the registry values –  Dana May 31 '13 at 17:18

its a simply answer really, you didnt let your computer load up completely before you went and started up programs. all you have to do is open up task manager, go to processes, end explorer.exe... the taskbar should close down, dont panic, just while you still have task manager up press [file] and then new task run, and in the section type explorer.exe, your taskbar should load back up with the normal icons. if that doesnt work then go n do some registry editting like that other dude said.

share|improve this answer

The easiest way in Windows 8.1 is to open Task Manager (right-click on the menu bar or CTRL+SHIFT+ESC), then scroll to the very bottom to Windows Explorer, right-click, Restart. The end.

Doesn't work on the Windows Explorer that may appear higher in the menu, must be under Windows Processes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.