Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Since QuickTime X came out, whenever I watch HD trailers from Apple, they automatically begin playing as soon as possible. Is there a hidden preference to disable that? My question may be similar to a previous question on QuickTime X autoplay for embedded videos. I'm assuming it's a defaults write thing…

share|improve this question

Open up terminal. Run the following command:

defaults write com.apple.QuickTimePlayerX MGPlayMovieOnOpen 0

Run this to turn it back on:

defaults write com.apple.QuickTimePlayerX MGPlayMovieOnOpen 1

You might need to restart Quicktime and/or the whole system for it to grab the new defaults.

Take a look at this Preferance Pane too, it will make changes to QuicktimeX easier until they implement preferences in the app itself.

share|improve this answer
    
Took me a bit of time to respond because I was testing it out a few different times. Doesn't work, either with the Preference Pane or with the command. Trailers from Apple autoplay as soon as they're loaded enough. +1 anyway for the Preference Pane. Didn't know about that. – fideli Jan 14 '10 at 4:33
    
Upon further investigation, it appears that the autoplay preference applies to files that I open from my computer, and not trailers that load from Apple's website. Hmm. – fideli Jan 16 '10 at 6:18

I've taken to double striking the space bar as soon as the QuickTime window opens. This starts and then quickly stops playback, disengaging autoplay while the trailer buffers. It isn't a proper solution, but as good of a workaround as I've been able to come up with.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .