Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use a speaker share program called "SpeakerShare". What it does is to share a speaker. I have a speaker on my desktop. I would like to use the desktop speaker from my laptop. When I try to use SpeakerShare, it says that it can't connect to server. I asked the author of the program and got reply from him:

This is a network related error. There must be something blocking packets from client, maybe it's your router. Or maybe another instance is running on the server computer. That's all I can say for now. I tested on two machines Windows 7 installed without problem. Can you post here if you make it work?

I am using windows 7 on both laptop and desktop. I disabled firewall completely, but I still can't connect.

Is there any other software that I should disable?

share|improve this question
Like mentioned from the given answer, it could be from your router. What do you use as a router, to connect between your laptop and desktop computers? It could be filtered by it as well. – Gnoupi Jan 12 '10 at 9:24
@Gnoupi // I disabled everything. This is very weird.. – user45326 Jan 12 '10 at 9:30
up vote 1 down vote accepted

To be sure if this is linked to your router, or only to computers, you could try to connect directly the two computers, without a router in the middle.

This way, you would be sure if the router is the cause or not.

You can find a tutorial here, if needed.

share|improve this answer
Good point, but just in case: isn't the Windows firewall configured per network? And if so: doesn't the above create some new additional network, hence with its own firewall settings? – Arjan Jan 12 '10 at 10:00
According to his question, he deactivated Windows Firewall completely, so this shouldn't be an issue. – Gnoupi Jan 12 '10 at 10:09
Obviously the problem was on the router side, if that was accepted. – Gnoupi Jan 12 '10 at 14:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.