Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I made a multi-level bulleted list in TextEdit that looks something like:

  • foo
    • bar
    • stuff
      • things

However, when I try to convert it to text (via cmd-shift-T, copy and paste, or textutil), the result looks more like:

  • foo
  • bar
  • stuff
  • things

How can I convert to text but preserve the indention?

share|improve this question
add comment

2 Answers

This is because you are using the RTF only outline formatting that a plain text file can't handle. You can create your outline manually with tabs to indent and type the bullets with option 8 and when you convert to plain text you will get the result you are after.

Edit: I was able to preserve formatting by:

  1. Install PlainClip
  2. Shift click to launch Plain Clip and enable "remove trailing spaces and tabs from each line" and "remove invisible control characters"
  3. Copy from the RTF file
  4. Click on PlainClip
  5. Paste in a new RTF file and convert to TXT
share|improve this answer
    
Surely there's a way to use applescript or somesuch to convert the ruler formatting into spaces or tabs, though. –  Dan Jan 13 '10 at 22:19
    
See edited answer. –  ridogi Jan 14 '10 at 0:39
    
Doesn't do it for me - I still get all of the bullets on the same level. –  Dan Jan 14 '10 at 17:39
    
Exactly followed the instructions, but failed for me. –  porg Jan 10 at 11:12
add comment

Hmm, it looks like catdoc could probably do this. I was hoping that antiword would be able to do it as well, but I don't see any indication that it can either on the website or in the manpage, so maybe not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.