Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For some reason the internal links in Gmail stopped working for me today.

Clicking on a link like "Inbox", "Sent Mail", "Drafts", etc. would change the address bar in Firefox, after a couple of secs a "Loading..." notice would appear and then nothing changes. Reloading reloads the whole site, and the correct page would be displayed.

Email viewing works fine, as well as returning to Inbox, but nowhere else (not Sent Mail nor Drafts for example). Search is broken, nothing happen for enter or button click.

Composing works as it should. External links (Calendar, Docs, Reader) are fine too.

This is really annoying, and I don't have a clue what could be the cause of it.

I'm using Firefox 3.5.7 running on Windows 7 Professional 64bit.

Solved: Disabling Add-ons revealed that the source of the issue is the RememberTheMilk.com Firefox add-on. It worked fine for a while, but as I recall I had a minor Firefox update recently, and I've noticed the problem sometime after this happened.

share|improve this question

closed as off topic by random Jul 3 '12 at 20:11

Questions on Super User are expected to relate to computer software or computer hardware within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

4  
have you disabled Javascript ? Installed new Add-Ons? Activated new Google Labs stuff recently ? –  Michael B. Jan 13 '10 at 0:18
    
If you have found a solution to your problem, try posting it here as an answer and marking it as the accepted solution. –  David Pearce Jan 13 '10 at 10:49
add comment

2 Answers

up vote 1 down vote accepted

Apparently my current Gmail version (I didn't even know there is such thing!) is unsupported by Remember The Milk at the moment.

So the actual solution for now is to "disable and wait".

share|improve this answer
add comment

Try clearing Firefox's cache.

To do this, press Ctrl+Shift+Del to open the Clear Recent History window.

Check just the "Cache" option and click "Clear Now".

Clear recent history window

share|improve this answer
    
Thanks for the suggestion, but didn't change a thing. –  shinjin Jan 13 '10 at 8:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.