Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just downloaded the "Server Admin Tools" from Apple. When I try to install it from the ServerAdminTools.pkg I get the usual "hello" and "read license" screens from the installer. When it comes to the page where it asks me to "select a destination", choose a hard-disk, it tells me that my primary disk cannot be chosen:

Server Administration Software can't be installed on this disk. 
You don't have permission to install the software on this disk.

I am working as "admin" and I usually get prompted to give my password in a similar situation with other software. I know the UNIX permission system but it seems I still haven't figured out how Apple adopted it...


Thanks to the answer of Marcin, I tried his suggestion. Turns out, the problem remains:

macbook-pro:temp me$ sudo installer -pkg ServerAdminTools.pkg -target /
installer: Cannot install on volume / because it is disabled.
installer: You don’t have permission to install the software on this disk.

How do I enable the disk then for installation of this, apparently holy, package?

share|improve this question
I modified my answer. Try it now. – Marcin Jan 13 '10 at 1:40
Looks like the Server Admin Tools version linked above are version 10.4.7. Maybe they are not compatible with my 10.6.2 snow leopard os. I will try with the latest version now: – raoulsson Jan 13 '10 at 10:05
Using the fitting version for my os worked! Thanks all for the great hints. – raoulsson Jan 13 '10 at 10:14
up vote 2 down vote accepted

Are you able to sudo with other commands?

Is your OS patched to the latest version?

Do you realize that Server Admin Tools are meant to be installed on Client OS, not on Server OS?

There are newer versions of Server Admin Tools than the one you linked to. Did you mean to download 10.5.7 or 10.6.2?

If none of those are the answer then this seems like one of those super rare cases where Repair Permissions (in Disk Utility) is actually the fix.

If that doesn't work you can also try creating another user and installing it from that.

Failing all of that, take a look at your logs when you try to install and see if there is anything of help there.

share|improve this answer
sudo works with other commands, I have client os 10.6.2, disk utility permission fix already run. Downloading the 10.6.2 Server Admin Tools now. Hope that helps. Thanks! – raoulsson Jan 13 '10 at 10:02

You can use sudo on Mac OS just like Linux systems that abstract the root account. What you can try is running Terminal. You can search for Terminal in spotlight if you don't have a convenient shortcut. When inside of terminal you should cd to the directory where the pkg file is. Once there run this command:

chmod -R 777 ServerAdminTools.pkg

Then run

sudo installer -pkg ServerAdminTools.pkg

That should go through without a problem.

share|improve this answer
Thanks for the hint. See my EDIT – raoulsson Jan 13 '10 at 1:04
Thanks, but still no luck. Trying latest versions now as ridogi suggests. – raoulsson Jan 13 '10 at 10:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .