Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to scp an svn dump to savannah, but I got the following error at the end.

Permission denied (publickey).
lost connection

The scp command and verbose output are below. Any ideas?

[wcyang@be2-wireless-pittnet-60-37 ~]$ scp -v diffcolor-dump.bz2
Executing: program /usr/bin/ssh host, user wcyang, command scp -v -t /srv/download/diffcolor/
OpenSSH_5.2p1, OpenSSL 0.9.7l 28 Sep 2006
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file /Users/wcyang/.ssh/identity type -1
debug1: identity file /Users/wcyang/.ssh/id_rsa type 1
debug1: identity file /Users/wcyang/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1p1 Debian-5
debug1: match: OpenSSH_5.1p1 Debian-5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host '' is known and matches the RSA host key.
debug1: Found key in /Users/wcyang/.ssh/known_hosts:1
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/wcyang/.ssh/identity
debug1: Offering public key: /Users/wcyang/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/wcyang/.ssh/id_dsa
debug1: No more authentication methods to try.
Permission denied (publickey).
lost connection
share|improve this question

migrated from Jan 13 '10 at 3:49

This question came from our site for professional and enthusiast programmers.

might get a better response on – Brian Jan 13 '10 at 3:44
Have you uploaded a public key to authenticate with? Is it the one matching the private key in ~/.ssh ? – sth Jan 13 '10 at 3:45
Use more v's -- scp -vv or -vvv should give even more verbose log messages. – Jim Lewis Jan 13 '10 at 3:53
Also, disregard any advice to post all the files under your .ssh directory so we can check them for typos. – Jim Lewis Jan 13 '10 at 3:53

Did you expect to be prompted for a password? If so, then something in your ssh or the remote server's sshd configuration's changed to disallow password authentication.

Otherwise, your debug output seems to be saying that your private keys don't match any of the public keys in the remote account's .ssh directory. Have you compared the ~/.ssh/id_? files on savannah to the output from ssh-keygen -y on your local box?

Another possibility is that the permissions on your .ssh files are too permissive. I believe I've seen that happen without any output, debug or otherwise, to hint at it.

share|improve this answer

This solved it for me:

ssh-keygen -f "/home/local/.../.ssh/known_hosts" -R

share|improve this answer
Can you explain those switches please? – Fazer87 Apr 24 '15 at 7:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .