Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Before i ask the question, let me point out that this is not a hardware issue. I have a clean install of vista on another hd that runs on same hardware, i am pretty sure its a corruption of a drive or a file, i presume it might be video driver.

When windows wont start via normal boot i just get black screen after initial load up of os, so i boot into savemode, I end up having black screen with a mouse pointer visible, after initial load of os. The shut down button is responsive.

Of course, I can install clean copy of os, and prior to that can retrieve all other files that i need by accessing hd itself, i can restore my pc from my external back up as well.

Although i have all these options, i was wondering if there anything else i can do that can help me fix this issue.

In save mode, it looks like I am capable of logging in after initial load of os, even though i cant see the process it self, i do see the mouse pointer. By visual memory i navigated to password field, and entered my password, hit enter, I get the loading mouse pointer, nothing really changes, same black screen and mouse pointer, but when i tried to access task manager for a second i got a safemode watermark at all four corners.

Any help would be appriciated. Thank you in advance.

share|improve this question
    
Safe mode doesn't load your video drivers, plus you are seeing the mouse and it works, as well you say the Safemode watermarks DO eventually show up. It's something else, but what that thing is, is hard to say. Have you tried booting from the Vista disk and performed a repair? –  techie007 Jan 13 '10 at 4:03
    
Yep, it just sas that there is nothing to repair, i did basic scan for files integrity. Via secondary install. P.S. This initially only was happening in normal boot, i was able to start up in save mode, but then something got corrupted when i tried to do disk check on next safe mode start. Very weird : / might be virus, but then again my anti-virus was running all the time and hypothetically should of taken care of that if anything. –  GnrlBzik Jan 13 '10 at 4:12
    
Ok - I'll go make an official 'answer'. ;) –  techie007 Jan 13 '10 at 4:36
add comment

1 Answer

up vote 0 down vote accepted

If disk checks seem to be making it worse, and it seems things are working in slow-mo (like the watermarks showing up) if they do work, then it sounds like a failing drive.

Go to the drive manufacturer's website and get a bootable set of diagnostics and use them to test the drive.

Most manufacturers' diagnostic tools have both 'quick' and 'extended' type tests. The Quick tests are mainly testing drive operations like head positioning, cache checks, and disk spin (etc.). If the quick tests detect a problem they will either fail outright and tell you to replace the drive, or say the error is 'repairable' and offer to run the extended tests to attempt the repair.

The Extended tests that can fix problems do a surface scan and remap bad sectors to spare areas on the drive (amongst other things).

A potential problem is that the extended tests generally don't try to resurrect the data before remapping. So if the quick test tells you there's a 'repairable' problem, and you want to keep as much data as possible, then I'd say check out Spinrite and perhaps run that to attempt to resurrect the data from any bad blocks before going back and using the manufacturer's tool to 'repair' the drive.

That's my best suggestion based on what I can 'see'. ;)

share|improve this answer
    
thank you techie007, i will test this this weekend and see if this will help me to avoid reinstalling. –  GnrlBzik Jan 14 '10 at 20:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.