Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, so I have an interesting setup going on.

Far away from me, is a headless (no monitor) Ubuntu box hooked up to an ethernet cable.
This computer is intended to be a public internet station at a hostel, it's just waitinig for me to finish the wifi configuration, and then the owner will put it in place, hook up a monitor, and that's it.

The computer HAS a wireless card, which seems to work (i.e., I can give it commands through iwlist).

  1. I have ssh access with X forwarding enabled.
  2. When I log in, and run ps -e | grep nm-applet I see it isn't running.
  3. I checked gnome-session-properties and nm-applet is listed there to start.

So my questions are:

What can I do to get nm-applet running? Maybe it's running and I can't see it? Otherwise, what can I do to set it to connect to WiFi automatically?

share|improve this question
add comment

3 Answers

It might be easier to use iwconfig. Here's a tutorial.

share|improve this answer
add comment

Well if its a wpa secured wireless network, you would probably start up wpa_supplicant, and then dhclient. you could prolly set up the box to start it at each reboot. there's NO reason to use nmapplet on a headless box

On one of my boxes, i have a script that starts both, - the commands for wpa_supplicant vary depending on the box, and you would need to set up a conf file, but this is the most straightforward way to do it.

this question might help - its solutions to a similar issue

share|improve this answer
    
ah, but it's not meant to be a headless box. As soon as it's on the wireless, it will be moved to another room, and have a monitor attached. –  Jono Jan 13 '10 at 20:25
    
if you don't need to roam, or its a cli box, its still the most straightwardward way. if you're running gnome, or kde, then well go for the nmapplet method –  Journeyman Geek Jan 14 '10 at 1:18
add comment

Recently I have managed to setup wifi for my slackware and blogged about it
In short, at the point that all the settings seemed to be done (while I still cannot connect), I just needed a command

dhcpcd wlan0

Hope that can help

share|improve this answer
    
Do you mean dhclient? That's not working. iwconfig tells me I'm on the network, but no IP address. –  Jono Jan 13 '10 at 20:37
    
you can look at my question here superuser.com/questions/84622/… it's dhcpcd, not dhclient, don't you have it? –  phunehehe Jan 14 '10 at 3:17
    
I don't have dhcpd running on the ubuntu box, because it's supposed to acquire an address, not assign it. –  Jono Jan 15 '10 at 9:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.