Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A friend of mine is having a huge problem with his new PC. He wants to install Windows 7 x64 but the installer doesn't find his Hard Discs. The discs are connected via SATA on a Asus P6T SE motherboard.

I think the problem is just that there is no driver available for the SATA-Controller and thus no discs are found. Yesterday we looked up the available downloads on the Asus Page and downloaded two drivers we thought that fix the problem. We put those drivers on a USB and told the installer to look there for additional drivers. But it didn't help.

I am not sure if it would work, but if he would have an internet-connection via LAN-cable would the installer be able to lookup additional drivers automatically or does he have to provide those manually?

Any help is appreciated.

share|improve this question

migrated from serverfault.com Jan 13 '10 at 20:01

This question came from our site for professional system and network administrators.

3 Answers 3

This question should be moved to SuperUser...

Anyway, You have to do it manually, you're on the right way by using a USB Key to load driver.

Try these : http://dlcdnet.asus.com/pub/ASUS/misc/sata/IMSM_V8901023_Windows7.zip

Of course the files should be extracted from the setup file on your USB drive so that windows are able to read it...

share|improve this answer
    
Thanks. I downloaded the file, but I cannot unpack the files any further. I tried the cab files as well as the setup files. I also tried to unpack with cabextract and unshield which are linux-tools for that purpose. On Windows I tried WinRar, but none of the tools could read it. I tried to install the drivers on my system so I have access to them, but the installer canceled because of my different system. –  user4747 Jan 14 '10 at 16:01
    
Ok, there's the real deal, at least it should be this : downloadcenter.intel.com/… extract them to the USB Drive and then try to load them in windows setup, should work :P –  Marc-Andre R. Jan 19 '10 at 3:45
    
Thanks for the help, but it was something else (see solution post) –  user4747 Jan 19 '10 at 10:15

have you tried to disable AHCI in the BIOS?

you can install Windows 7 in IDE mode and later change the settings to AHCI.

for more information see this thread.

share|improve this answer
up vote 0 down vote accepted

We were able to solve the problem yesterday and I have to admit, without a lack of communication it would have been solved earlier :)

After my friend told me that the Vista-Installer was once able to find the disk I was thinking that the controller or the disk might be broken. To check this I booted his machine with a Linux Live-CD to see if this is able to find the disk or if it is broken. But Linux was able to see the disk and I was able to create files on it. For an additional check I started the Linux Partitioner (KDE) and there I could only see the disk (sda) but no partition (sda1). After creating a FAT partition and rebooting, the Win7 installer could find the disk. I deleted the FAT partition, created new NTFS ones and all went fine.

So obviously the problem was a broken partition table and not the driver :)

share|improve this answer
    
Wow kind of weird issue... Glad you finally revolved it :) –  Marc-Andre R. Jan 20 '10 at 19:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.