Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using dropbox across several machines - two macs, two linux machines.

All are working happily - except for one mac, where there are 4 files that persistently refuse to update.

In finder, these 4 files have a red X icon. The dropbox menu is stuck on 'syncing' (and has been for about a week now), and has part of an error message saying that it can't write to these files.

In Finder's "Get Info", it says I have read+write access; at the commandline, ls shows that they have -rwxrwxrwx permissions.

share|improve this question
What kind of files are they? Can you execute them without Finder asking the "are you sure?" question, like when you download something from the internet and it warns you first. – Marcin Jan 14 '10 at 1:03
Does quitting and relaunching Dropbox help? That was all it took when mine was stuck on "syncing" a while back. If you search your logs for dropbox do you get any useful hits? – ridogi Jan 14 '10 at 1:17
@marcin: they're documents. Didn't try to execute them (but it would have been fruitless, they're not executables - I don't know why the x bits were set) – James Polley Jan 14 '10 at 1:40
@ridogi Relaunching dropbox didn't help, rebooting didn't help. Logs don't show anything useful. – James Polley Jan 14 '10 at 1:41
("didn't" rather than "doesn't" because I've already solved this, but my solution was esoteric; I'm hoping that someone else can come up with a better answer, but if not I'll just have to answer my own question so that the solution is at least documented) – James Polley Jan 14 '10 at 1:50
up vote 5 down vote accepted

The HFS+ filesystem includes flags, which provide extra permissions on top of the usual Unix permissions. One of the flags is "unchangeable" - which does what the name suggests.

Several files inside my dropbox had been flagged as unchangeable. You can check for this with ls:

Sombrero:directory polleyj$ ls -Ol
total 0
-rwxrwxrwx  1 polleyj  admin  uchg 0 15 Jan 23:29 file1

-0 tells ls to show the extra flags; uchg indicates that this files in unchangeable.

Sombrero:directory polleyj$ rm file1 
override rwxrwxrwx  polleyj/admin uchg for file1? y
rm: file1: Operation not permitted
Sombrero:directory polleyj$ mv file1 ..
mv: rename file1 to ../file1: Operation not permitted
Sombrero:directory polleyj$ 

To fix this, use chflags:

Sombrero:directory polleyj$ chflags nouchg file1 
Sombrero:directory polleyj$ rm file1 
Sombrero:directory polleyj$ ls
Sombrero:directory polleyj$ 
share|improve this answer

I ran into the same problem and found out one of the directories in Dropbox was owned by a different user. Running chown on that directory cleared up the sync issue.

share|improve this answer
Now that you mention it, that makes sense. Having the "unchangeable" bit set means the file can't be modified; having it owned by a different user would have the same effect (and presumably produce the same symptom). – James Polley May 14 '13 at 4:33

I found another hitch that prevents Dropbox from synchronizing specific files and folders, that isn't mentioned anywhere else: If you use certain special characters like for example backslash \ in the Dropbox folder or file name. See: Certain files won’t sync in Dropbox.

share|improve this answer
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – DavidPostill Oct 3 '14 at 12:09

1) Your Dropbox is on a network share that is disconnecting and reconnecting (restarting may help) 2) You're over your quota. You should remove files (or upgrade :-).

share|improve this answer
Nope. 54% of Dropbox quota, and the local copy is on my laptop's hard drive – James Polley Jan 14 '10 at 2:04

I had a red cross icon next to a pdf someone else sent me. I saw it for about three days. What I did was copy the pdf in the Desktop, changing its name. In the pdf information, just in case, reduced my privileges to "read only". Then logged off from Dropbox in my three macs, and logged in to Dropbox via the internet. Then permanently deleted the reluctant pdf. Finally, logged in again my laptop to Dropbox, and copied the pdf, from the Desktop to the right Dropbox folder. The red cross disappeared. Now I have logged in to Dropbox via the desktop in my other computers and there are no more red crosses in that famous pdf. Hope it helps.

share|improve this answer

Sometimes you just need to wait. Go to the Dropbox icon in the menu bar and check the status ticker. It will tell you what it's doing. I had a video file with a red cross for about an hour while either Dropbox or El Capitan sorted something out preparing it for upload, then it just started of its own accord. An hour later (big file, s-l-o-w internet), it changed to the blue uploading icon, an hour and a half after that, to a green tick.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .