Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install PHP's Zend Server on my CentOS VPS but it's having dependency issues that I can't seem to resolve.

zend-server-php-5.2-4.0-73.noarch from Zend_noarch has depsolving problems
  --> Missing Dependency: php-5.2-gui-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
zend-server-php-5.2-4.0-73.noarch from Zend_noarch has depsolving problems
  --> Missing Dependency: php-5.2-dev-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
knowledgetree-ce-3.7.0-2.noarch from KTnoarch has depsolving problems
  --> Missing Dependency: php-5.2-xmlrpc-zend-server is needed by package knowledgetree-ce-3.7.0-2.noarch (KTnoarch)
knowledgetree-ce-3.7.0-2.noarch from KTnoarch has depsolving problems
  --> Missing Dependency: php-5.2-fileinfo-zend-server is needed by package knowledgetree-ce-3.7.0-2.noarch (KTnoarch)
zend-server-php-5.2-4.0-73.noarch from Zend_noarch has depsolving problems
  --> Missing Dependency: php-5.2-zend-extensions is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
zend-server-php-5.2-4.0-73.noarch from Zend_noarch has depsolving problems
  --> Missing Dependency: php-5.2-common-extensions-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
Error: Missing Dependency: php-5.2-fileinfo-zend-server is needed by package knowledgetree-ce-3.7.0-2.noarch (KTnoarch)
Error: Missing Dependency: php-5.2-xmlrpc-zend-server is needed by package knowledgetree-ce-3.7.0-2.noarch (KTnoarch)
Error: Missing Dependency: php-5.2-gui-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
Error: Missing Dependency: php-5.2-common-extensions-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
Error: Missing Dependency: php-5.2-dev-zend-server is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)
Error: Missing Dependency: php-5.2-zend-extensions is needed by package zend-server-php-5.2-4.0-73.noarch (Zend_noarch)

When consulting the Google, all I get told is how to install PHP 5.2.* on CentOS. According to the output of php -v, I've done that.

PHP 5.2.8 (cli) (built: Sep 28 2009 15:37:15)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies with the ionCube PHP Loader v3.1.34, Copyright (c) 2002-2009, by ionCube Ltd.

How can I solve this issue?

share|improve this question

1 Answer 1

You can grab all of the dependencies from zend's repository.

share|improve this answer
    
I have the Zend repo added to my YUM repo.d folder. It still doesn't resolve the dependencies. Performing a yum search [package] also returns no results. My Zend Repo file is here codepad.org/oGALx5Em –  rax Jan 14 '10 at 3:53
    
Try downloading them from the link and using rpm -i ? –  John T Jan 14 '10 at 4:01
    
Which package version should I download? No version is specified in the YUM output, so should I just grab the latest version? For example, php-5.2-common-extensions-zend-server-4.0-19.noarch.rpm ? –  rax Jan 14 '10 at 4:02
    
Try the latest, yes. –  John T Jan 14 '10 at 4:07
    
That just gave me a nice big list of other dependencies I'm going to have to install by hand >.< There's gotta be a reason why the /etc/yum.repo.d/zend.repo file isn't working... I'd rather not do this manually. –  rax Jan 14 '10 at 4:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.