Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Trying to install Reuters Messaging software onto a windows 7 pc we receive the error message

Error 1324: The folder path 'My Documents' contains an invalid character

We've tried installing the application using the local admin account and the user account which is an AD account (roaming?). This user account has administrative rights (i.e. should be allowed to install applications).

The users 'My Documents' folder is located on a network drive, where only the user has access.

We've tried experimenting with the

HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer\ User Shell Folders

registry entries and setting them to a local position (i.e. C:\Users\Username\Documents) but this didn't resolve the error.

We've also tried the following which was taken from a website I can't remember the name of:


Select the NtfsDisable8dot3NameCreation entry and change the value to 0

Select the Win31FileSystem entry and change the value to 0

which didn't resolve the issue.

Edit: This was also an issue when attempting to install the citrix native client necessary to run citrix application (*.ica extension). This made the same error box appear.

share|improve this question
up vote 1 down vote accepted

Apparently the answer was a simple solution that I'd overlooked (because it was so obvious..)

If I instead of attempting to run the program as administrator under a normal account, login as the local administrator account from the login screen, I was able to install the program without any issues.

The normal user was then able to subsequently launch the program via the launch/start menu.

So the solution was to use the local administrator account to install the software. Who would have known?

Sorry for having wasted peoples time with such an obvious thing....

share|improve this answer

Instead of editing the registry can't we use more graceful method like this.

share|improve this answer
I tried to change the location of the Documents folder using the instructions on the page that you posted (changed it to a local folder). However, upon double-clicking the windows installer the same error message still appears. – llykke Jan 14 '10 at 14:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .