Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After restoring from backup following filesystem corruption my user account hangs after login (After entering my password the login window disappears and all I get is the background and a mouse pointer, no spinning wheel of death etc ..) I can login as a different user and then logout and login as my main account (sometimes!) but this is not consistant.

I can login with safemode ok and have tried deleting /System/Caches, ~/Library/Caches and removing all my ~/Library/Preferences which worked once but not again.

Does anyone have an any idea which logs I can look in, if any, to see whats happening after login or any other tips?

I'm using 10.6.2.


share|improve this question
up vote 6 down vote accepted

If it works in safe mode, you should check the things that get disabled in safe mode. Since this problem only occurs in the login session, the prime suspects are probably login items (check in System Preferences -> Accounts -> your account -> Login Items tab), LaunchAgents (check both /Library/LaunchAgents at the root of the boot drive, and ~/Library/LaunchAgents in your home folder; note that items in /System/Library/LaunchAgents are not disabled in safe mode, so aren't suspects), and fonts (again, check both /Library/Fonts and ~/Library/Fonts). Experiment with disabling the various items to narrow down which one's causing the problem.

share|improve this answer
If the problem is specific to the login items, one could just login with Shift held down ( instead of doing a whole safe boot. If it still fails, then try a safe boot. If it works, then one only has to check the login items instead of all the stuff a full safe boot disables. – Chris Johnsen Jan 16 '10 at 17:35

I had that same problem. It got resolved when I entered the account in Safe Mode, and uninstalled Little Snitch. I reinstalled it later, when I could enter the account without any further problems.

share|improve this answer
Little snitch was infact the problem!. I'm accepting the answer above though as it may be more helpful to solving similar probs. – user11304 Jan 19 '10 at 16:34

You must log in to answer this question.

protected by BinaryMisfit Nov 5 '10 at 13:42

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .