Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

While i work, I listen to music using headphones plugged into the headphone jack on my MBP. Sometimes the music is streamed via iTunes radio, but usually mp3 files played through iTunes.

Obviously, to eliminate sound from other sources, you have to do more than just press the 'mute' button. The two annoying sources are: (i) sound effects from Mac OSX; and (ii) from websites (either music or ridiculous sound effects like the sound of a camera shutter when you click a link--stuff like that.

The first type is easy enough to deal with: System Prefs > Sound > Sound Effects : then uncheck "play user interface sound effects" and just for good measure move the slider above this checkbox all the way to the left. (The Sound Effects Volume slider is separate from the Output Volume slider, though both are on the same panel).

It's the second source that i don't know how to get rid of. I thought that surely there's got to be a small shareware app out there from an indy mac developer (for which i'd gladly pay $10-$15), or a browser plug-in for Safari--but no luck.

share|improve this question
    
Windows Vista/7 have per-app volume settings - I'd be surprised if OS X didn't have something similar, though maybe a little hidden away. No real experience with the OS, though, so I can't help! –  Phoshi Jan 14 '10 at 15:22
add comment

2 Answers 2

up vote 0 down vote accepted

I use FlashBlock for Firefox. I believe ClickToFlash is the same thing for Safari.

Of course that doesn't deal with other ways a browser might make noises, such as other plugins (I don't run any anyway, for security reasons; I don't know if you can remove the QT plugin on Mac though) and HTML5 <audio>. The latter is still rare though. Almost all the real-world obnoxious auto-noisy sites are doing it with Flash.

As a bonus, you get to restrict Flash cookies which otherwise make a mockery of your privacy settings.

share|improve this answer
add comment

In Safari, go into preferences. By disabling "plugins" that should kill the sounds for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.